Nuki-Opener ifttt service and other services not usable one time!?

I use nuki with ifttt and nuki just don’t work properly with the different services!? Nuki-Opener and Nuki-Lock are two different services, and for the lock service - just “leave home” is the only thing what works, “come home” never worked just for one time, for the opener service - it just doesn’t work at all, no matter what trigger, no matter if over Google-routines or Alexa-routines or ifttt, it worked not one single time!? Also the ring cam should show a nuki button on the live view, for opening nuki app out of ring app, not one time the button shows up!? I try this now for months, and nuki has a real issue to work reliable with other systems (skills&services&link), and it gets really annoying now!? I have reported this several times, and someone have to look at this finally, the things don’t work as advertised!? Please solve this finally!

1 Like

I answered on your IFTTT opener service request here:

If no triggers are running for you for all integrations I highly suspect an issue with activity logs in Nuki Web, but as you wrote you are already in contact with our customer support, this should have been checked?

I’m having issues with IFTTT as well. (Nuki Smartlock 3.0 Pro/Nuki Bridge/Nuki Opener)

The Smart Lock and the Opener disconnect after some time (Minutes? Hours? Randomly?). And the applet fails. I need to reconnect the IFTTT Opener and Smart Lock services to make it work again. For some time… until the devices are offline again.

Yeah sorry, made anyhow two threads about the same issue! I answered you on the other thread, and will close this one here! Very thanks!

I accidentally made two threads about the same issue, a very nice Nuki-Employee answered and we look on the issue there, please come also to this thread for further activity! Thanks!

I just received an answer from the IFTTT Support:

Dec 10, 2021, 5:12 PST

Thanks for providing all the details.

I checked the logs and there is an error that is coming back from the Nuki server when those actions fail - {“message”:“Unknown error occured”}​. It’s not a common error with Nuki as far as I can tell. We don’t have further visibility in this, have you tried reaching out to Nuki support about it? Let me know if that doesn’t work and I’ll see if I can connect with their team responsible for the IFTTT service.

Art from IFTTT

So they say it’s just another problem at Nukis side…

Big news, dont now if they have done anything, but I reconnected both nuki Services for lock and opener before a minute ago, and all worked immediately!? I dont know how often I reconnected the Services and it never solved anything, but yet it worked, and I really hope it keeps that way!? Please reconnect now both nuki Services and try again! Let us know, if it works!

Yeah… For me it works for some time. A few hours. Then it stops again.

Yeah thats also my concern, that it will stop working after a time!? For now, I just can test, but I wrote the nice Nuki-Employee that I test a bit and get back to him, and also the support is on it, so I think if it brakes down again, they will really look at it, I think!

For me, it also doesn’t work the other way around.

I had some success calling the web API directly like that:

curl -X POST --header ‘Content-Type: application/json’ --header ‘Accept: application/json’ --header ‘Authorization: Bearer XXXXXXX’ ‘

But that also did not work reliably.

Maybe it is a power management issue with the Smart Lock 3.0 Pro/Opener/Bridge setup?

As we thought, a few minutes ago I got a message from ifttt that the locks are not reachable anymore!? This just doesn’t work!? Really annoying!

Now it gets really strange, the ifttt logs show that the trigger fires all the time now with no real trigger happened, and it fails then all the time!?

Ok… I might found one the issues. Maybe. We’ll see.

I realised, my lock is not reachable over anything other than Bluetooth. Even inside the Nuki-app itself. So neither the connection over the Nuki Bridge nor the connection over the built in WiFi worked.

So I resetted the connection as described here:
Fehlerbehebung: Fernzugriff über das WLAN Modul (German /

After the reset, the lock showed a critical battery state. (After about a month of unreliable operation.)

That does not explain the problems with the opener in IFTTT…

It’s an incredible frustrating situation. :frowning:

Yeah really frustrating, at first someone from nuki answered and said I should pm him what I have, but to now no response, the support over app I contacted even before here and also to now no response, and the funny thing is, yesterday I got a email how satisfied I am with the support!?

No. It worked, and now it doesn’t work anymore.

Now both services disconnect at the same time?

Yes, this happens to me since a few days again and again!? Look in the log of ifttt, if your triggers fire now all the time but failing, - I think because they fire all the time but are failing, the ifttt system shut the Services down, at a time!? And no response from nuki, not here and not over the support in the app!?

Today nuki responded and said that they have momentary much to do because they answer more slowly, and that the issue is given further to the right people, and to wait a bit longer! So I hope they look now over this.

Thanks for the additional information.

Both things should nor occur of course and we will continue looking into it.
As always please recheck if the data and online status is correct in Nuki Web and best also send screenshots for those times to our support.

The disconnect looks like an API token issue/reachability issue. Do you have any other integrations running (with the same issue)?

Have sent this information and pictures to the support, thanks! And I checked several times, and data and online status of nuki web is perfect, but the both ifttt services for nuki lock and opener will disconnected again and again from ifttt, and the reason for this I think is, that the trigger fires exactly all 5-minutes again and again without a real trigger, but are failing all the time, and this runs until the Services get disconnected from ifttt from itself!? And no, I have no other integration what have this issues, they all work well!