Nuki Lock 2.0 works erratically

We experienced several times the following situation:

  • I unlatched the door by using the IOS app (2.1.1). No Autounlock because I didn’t left the geofancing zone.
  • The door opened and I entered the room.
  • Now Nuki (2.3.11) started locking when the door is still open! And yes, we have and use the door sensor. As you can see in the protocol the sensor worked correctly. Autolock is disabled in the app. Now I can’t close the door and have to wait til Nuki stops. The lock is closed and the door is still open.
  • After that Nuki started to unlock again.
  • In addition: my unlocking command does not appear in the protocol!

What irritates me is the Positionserkennung/position detection in between. :thinking:

Please send a log-file with a short description of the problem to our support team at, so they can check the details of what happend.


Ich have the same problem.
The door was unlocked and stand open. Now the Smartlock closed and opened the door. In the Protokoll stands “Positionserkennung”.

My Hardware: Nuki 2.0 latest software App and Smartlock. Doorsensor enabled.

Ich tried also to disable the doorsensor with the same behavior.


“Positionserkennung” could mean that it restartet for some reason

Please also send a log-file with a short description of the problem to our support team at, so they can check in detail what happend.

I have exactly the same problem.

Same here with “Positionserkennung”

Is HomeKit enabled & paired?

No, homekit is disable. I only use android, web, fob and keypad.

Yes, homekit is enabled.

@MatthiasK: I send a log file to your support team. But no reaction yet.

Please make sure that your Smart Locks are part of the beta program ( There will be a new firmware within the next few days, which we’d like you to test.

1 Like

It looks like the problem is solved by installing beta firmware 2.4.0

There is now a new Beta FW 2.4.1 available. Please give it a try and let us know if you still see random “Positionserkennung” / “Position Detection” entries in the log.


with the new firmware 2.4.1 no more issues regarding “Positionserkennung”

the issue is back again

The issue is still unsolved with 2.4.1.

with the firmware 2.4.1 it was solved for me. no more issues “Positionserkennung”

please check the batteries. The original batteries were empty very quickly. then have “eneloop pro” used and running for 2 weeks without issues.