Nuki fails to trigger IFTTT - no error message

Dear everyone!

After spending hours of trying to fix this myself and failing miserably, I have to turn to you guys. There are many smart people out there and I hope some of them will read this post and help me out!

I’ll quickly recap the situation to avoid countless edits due to my lack of thoroughness.

The Setup:

  • Nuki Smart Lock
  • Nuki Bridge
  • Nuki Web Account
  • IFTTT account linked to the Nuki Web Account

The Issue:

In a sentence:

The IFTTT applet is not triggered by the selected Nuki action.

In more details:

I have an applet on IFTTT, which is triggerred by the Nuki Smart Lock’s locking (there is another one which has the same issue, which is triggerred by the Nuki Smart Lock’s unlocking).

I created these applets more than a year ago, and they were triggered several times a day without any issue.

The error started occuring an evening, but no changes of any kind were made by me before that first occurence, which could explain the error (no updates, not changes of account name, no changes of any sort really, neither on the IFTTT side nor on the Nuki side).

There is one way to get the applet to actually work, forcing it to run, from the IFTTT side by clicking the “Check Now” button.

I tried changing the username, changing the password, updating the settings, reseting the lock and the bridge, and even changing the batteries in the lock. I also tried reconfiguring the applet in IFTTT, and my account in Nuki, syncing the new settings and testing it out, and it never worked.

Since then (I tried a bunch of possible solutions for a day then I stopped), I received an email from IFTTT that is best recapped by the header “Nuki Smart Lock is still offline”.

The applet still only works on a “forced” run when I press “Check Now”.

Another test I ran:

I tried to create a new IFTTT account and link my Nuki account to that to test if that way the trigger worked with a random applet I created.

Spoiler: It didn’t.

I thought maybe there were some conflicting things in the account and wanted to test a fresh IFTTT user to see if that could be a workaround, but it was not unfortunately.

What could it be?

I’m not even sure where the error lies.

All other accounts connected to my IFTTT account work, triggers included, only the Nuki account does not.

On Nuki Web actions seem to work properly and be logged properly.

Anyone has an idea about how I could fix this?

Thank you for reading through all this! If you have even the most wicked sounding idea, I’m more than happy to hear it!


Same problem here. Since a few days no triggers are sent to IFTTT anymore… It started on an evening on March 4. Since then, no triggers are sent to IFTTT. There were also no changes in settings or configuration, it just stopped working at that evening…

Hey @sfreek!

Well at least it is good to know that I’m not alone! At the same time it’s unfortunate to find out that this an issue probably faced by others too.

Have you found any sort of solutions for this issue, or it wasn’t that important for you to fix?

Even if you found a workaroud that would be great to know!

Thanks for the note! We are looking into this issue if it could be anything on our side.

Hey @MatthiasK !

Thank you for your reply!

Do you want me to send you my applet ID or anyhting of the sort so that you can take a look at the logs?

I wanted to check those out on the IFTTT side, but I could not find a way to access them unfortunately.

Hi @tows

It ist very important for me since I run an autolock when the door has been closed and some other security related applets for my security cams…

Yes, if you can send me your Applet version ID (not the general Applet ID but your personal one) via DM, I can check the IFTT Logs for the last 48 hours.

Hi @MatthiasK

Thanks for looking into this!

1 Like

Thank you @MatthiasK I’ll send that to you then (just need to figure out how to DM you).

Click on my name and then on the “Message” Button.

1 Like

Well I hope there will be a solution, because it would be quite an issue for me too, if the error persisted like this.

I’ll keep you in the loop in case there is any update that could lead to a possible solution to the problem!

Hi, I’ve the same problem, since beginning of March, maybe due to firmware upgrade 2.10.8? Thanks in advance.

Also had this issue the last week too (Nuki Opener + IFTTT). Mine triggers eventually but it usually takes 5 minutes where as before it was less than a minute.

Hey @esoriani !

I don’t think that would be the issue, though I’m not sure of course, but the troubles on my side started before that update, so it does not seem related, though maybe there is a link to that, based on what changes happened in the backend maybe.

Let me know if you figured out any solutions to that!

Hey @Svenning !

I don’t think that that issue comes from the same cause than this one. Have you checked in the Nuki app under “Manage Smart Lock” - “Energy Saving Mode”, the frequency that is set?

I also was facing a similar issue some time ago, and changing that to a faster syncing between the bluetooth actions and the bridge registering those online fixed that. That is to say, a speedier synchronization fixed the incresing delay between the action and the trigger!

Let me know if that changed anything, I’m interested in knowing :slight_smile:

It’s set to automatic and I’m also in Debug mode… I can try to change it to fast as and see if that changes anything. In my experience what you are talking about is only having an effect on Nuki notifications are delayed or not showing up at all (which also delays IFTTT). That’s what’s been my issue in the past (I’ve had a couple of threads about this). Is that IFTTT not getting triggered at all and the only way I could get it to work was to activate Notifications that somehow forced the IFTTT to get triggered faster. But I haven’t experienced this where my Notifications are coming almost instantly but the IFTTT is not getting triggered. In general it feels like there’s some server side issues on Nuki side since a lot of threads I’ve seen are talking about delays.

I have as well the same issue here as initially described by David. It happened a couple of day ago I personally think after the upgrade to 2.10.8.

Hope a solution will be provided soon.

1 Like

In my opinion it could not be the firmwar update because I did mine after the triggers stopped working!

@tows @sfreek @esoriani @Svenning @Claudio_Granella

In coordination with IFTTT support we could track down and fix the issue and everything should be working as expected again.

EDIT: For clarification: It was not connected with the firmware update in any way.


Thank you again @MatthiasK !

It is fixed @sfreek ! :slight_smile: I also just checked, and it works again for me!


1 Like