Nuki 3.0 Pro looses connection despite AP is next to it

I had the same issue with my Nuki 3.0 Pro and UniFi UAP-AC-Pro.
Playing around with Wifi Settings by

  • enabling “Multicast Enhancement”
  • lower densitiy of “802.11 Rate and Beacon Controls” to 6Mbps
    and magically my Nuki 3.0 Pro Built-In WIFI is able to connect to my UniFi UAP-AC-Pro.

I have so much trouble with this device and they do not want me to return it that I’m considering a lawsuit.

Just today we were away for half a day and the app said the door was locked where it was not locked. See the attached image (as a new user I can only attach one image - I have 3 different timestamped images - feel free to contact me if you would like the original images). This device should not be sold in its current state.

This device feels like handing out ‘Get in for Free’ tickets to burglars.

Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

Thanks for reaching out, Jürgen, but I’ve tried contacting support too many times without any result.

Hi, my Nuki 3.0 Pro no longer connects to wifi, the pad does not take a fingerprint, after spending a lot of money between the door sensor pad lock and the cylinder, a quite unacceptable situation

There was a server outage today in the morning. You can check Nuki Status Dashboard – Check the Status of Nuki Services for the state of the API. Else please contact our support via the Nuki App (Menu > Help > Contact Customer Support) for more detailed information.

This forum is focused on developer related issues.

Same here with asus gtax 11000 pro
Modem distance 3 meters

Pretty unreliable when you have have rely while being away. Lock 2.0 was working fine with separate hub. Lock pro 3.0 is a disaster. I have TP-Link Omada wifi setup, every device works on lock pro 3.0 is disconnecting where day. Any ideas ?

1 Like

ALI yes play with wifi channels… 1…6…or…11
i did …

Same problem. SL3pro, 3.7.2 beta. Trying to set mqtt HA…( no wifi connection - 3m clear from main wifi Deco.

I have exactly the same problem.

I have had a Nuki 3.0 regular lock with a Nuki bridge. My setup is:

  • internet through the modem of my provider. Modem is in bridge mode.
  • from the modem a utp cable to a Tp Link Deco M9 plus. This is in router mode.
  • From the Deco a utp to a Tp Link Poe Switch.
  • From the switch Two utp cables to Two seperate Deco M9 Plus.

So i have a cabled backhaul between my Deco Mesh system. I set up Two WiFi networks. One private and one guest network for my BnB wich i have next to my Home.

I used the regular Nuki 3.0 with bridge for over a year and a half without problems. But since a couple of months the bridge lost the WiFi connection several times a day. The connection would get lost and it reconnected within a couple minutes. Sometimes it took longer. It did that for More than 8 times a day.

I did everything to fix it. I changed the preferences in the router so that the Bridge would only Connect to the Deco that is 2 meters away from the bridge. Also set up that the bridge would only Connect through the 2.4Ghz network.

This didnt help.

I then gave the bridge a fixed ip adress in the router and turned DHCP in the bridge off.

This didnt help either.

Next i contacted Nuki and got a replacement bridge because we thought it was defective. And guess what the new bridge did exactly the same.

Because i got fed up with this and because i use the lock for my BnB i bought a Nuki 3.0 Pro with the WiFi build in. I hoped that it was a flaw of the bridge and that this would not happen with the pro.

You can guess what happens. The exact same problem with the Nuki 3.0 Pro. I tried al the same settings with the 3.0 Pro and nothing helps. The Pro even stays offline longer. It sometimes reconnects after several hours!!

I also tried to Connect the 3.0 Pro to the guest network where is absolutly no traffic. But this doesnt work either.

I have no problems with other devices. Everything works perfect except the Nuki.

Due to my above findings and that it worked fine in the past i really think that there is a firmware problem!!

Please Nuki look into this!

I use the lock for my business and even have the smart hosting wich i pay for every year to have the lock arrange everything automatic for me. But when the lock is offline it does nothing. It doesnt create codes and so on. So i have to check daily if everything is ok. I also dont get the notifications real time when the lock is offline. So it actually is useless to me now.

1 Like

As a new customer of a Nuki 3.0 Pro I just found this long thread about my problem. Using a FritzBox 7590 AX (3 Meter of range) I get constantly WLAN disconnects and it does sometimes recover.

What I noticed during setup that it complains about a wrong password which wasn’t. After trying often enough the connection works and stays sometimes more than a day (which makes it hard to troubleshoot as it looks like a gambling game)

So I assume you used some new or faulty library or an own implementation of PKCS #5, RFC 8018 for the password which would make sense as the same method is used for reconnecting. Probably using the same for Nuki Bridge? Somewhere I read about similar problems.

There is a separate topic for 7590AX: FRITZbox 7590 ax issue with Wi-Fi smart lock 3.0 pro - #70 by Juergen

Hello, I was also wondering why my Nuki3Pro performed that badly, even an AP is more or less next to it. I have 2 UniFi UAP-AC-Pro and 1 Long Range in my house and usually the retina falls out of your eyes, due to wifi strength. I thought that might be the problem that the device can’t decide to which AP it should roam to. Anyway, I stumbled upon this post an tried the 2 settings above. The circled area are with the new settings:

as you can see, the connection quality rises, but is still far away as it should be. An ESP32 which is connected to the same AP at more distance looks like this:

Any more hints why the lock performs so badly with (UniFi?) APs?

The Nuki 3.0 Pro disconnects from Wifi when it can’t reach the Nuki Cloud over the Internet. So your problems may not be Wifi related at all.


How do you measure performance?
Is it slow or unreachable?

It was more or less unreachable until I made the changes suggested by TriNi:

  • enabling “Multicast Enhancement”
  • lower densitiy of “802.11 Rate and Beacon Controls” to 6Mbps

now it seems all the time reachable, but with a poor connection which I do not observe with other IoT devices

This is most likely due to the power saving mechanisms of the Smart Lock (it’s running on batteries, which most other devices don’t) and has no real life impact. i.e. in reality it is not “poor”.

If you are on a beta firmware, you can try to change the power saving of the Smart Lock to “middle” and set your networks DTIM to 3. This might increase the “WiFi experience” score, but will reduce the battery life of the Smart Lock (with no added value).

The comparison of wifi quality with USB powered devices might be a bit unfair, though. I understood, that a battery powered device has not always a good connection. My point would be rather that some tweaks in the unifi controller significantly improved the connection quality:

Screenshot 2023-09-18 145627

however, there are still some “off”-times which means that the door lock can’t be controlled with wifi (home assistant). But this is a central KPI - at least to me. Furthermore, with other APs, it seems to work better? This and the tweaks I made let me think we are looking at a software related issue, right? Either on unifi or nuki side. I would already be happy if I find the right tweaks to get to a stable connection. Any suggestions what might cause the issues with my UAP-AC-LR AP?

Maybe there is something in this post that helps: Smart Lock Pro working with Ubiquiti Unifi