Nuki 3.0 Pro looses connection despite AP is next to it

I have now Installed 3.5.1, it connects to my Fritzbox but still not to my Unifi Aps…

With my Unifi APs it says „Wrong Password“ when i try to connect it. The Fritzbox connects perfectly and shows it as connected in the connectivity overview. I will keep an eye on that if it stays connected. But stays poor for the unifi APs, I used it 6 months without any issues…

After updating to version 3.5.1, the connection to my (LANCOM) APs is very stable so far. No connection interruptions. :+1:

One more point to improve the WLAN information in the app would certainly be to display the signal strength in the app (connection status). If necessary, even endpoints via the API, so that you can at least see how the WiFi signal strength is.

I will continue to monitor it, but I think the improvement here definitely works currently.

Smart Lock > Features & Configuration > Built-in Wi-Fi > Tap 7x on “Network”.

1 Like


Thanks. To many hidden features for me… are there others? The Debug 7x tap is also known.

We suspect that the “2G rate control” (& auto optimize) setting can cause this behavior and that it might take several retries to initially connect the Smart Lock if it is switched on. This has also been disabled in our recommended settings for Unifi APs.

Could you try to disable it and check if that solves the problem in your network?

1 Like

I‘ve already disabled the 2G setting and set it to 1mbps, but I‘ve enabled UAPSD, BSS and Proxy ARP, now it connects instantly and stays connected since 10 Minutes… I will keep an eye on the connection.

But why was that behavior triggered after the firmware update? It worked with my ap settings before…. Anyways, I will keep you posted. My current FW is the 3.5.1.

After updating to version 3.5.1, the connection to my Fritz!Box 7590 AXs is stable so far. No connection interruptions.

Can someone tell me if i can return it all, im done with this tbh this should work. Spend over 300 euros and it does not work bought nuki august 1,

I’m joining in here. My SL3 Pro was connected just fine and suddely looses connection and I cant reconnect. Trying to do so also gives me horrible UX. I’m on beta firmware for some time now as I’m (trying) to test the new MQTT feature, but without WiFi this wont work. I have a Bridge as well and no connection issues there but I’m trying to get rid of the Bridge using the MQTT feature.

  • Nuki firmware version: 3.5.2-beta
  • WiFi hardware: Edgerouter X router and Unifi access points, there is a Unifi 6 LR access point at 2 meter distance
  • WiFi config: I have already made a couple adjustments as suggested here

I created a screen recording of the issue. Nuki app will tell me it cant connect to WiFi. When trying to fix it the network connection keeps spinning. When trying to reconnect to the same network I’m sometimes greeted with an incorrect password but when it eventually sticks I’m stuck again with a rotating icon instead of the green connection icon that it’s connected. When disabling and re-enabling WiFi the last used network is not saved and I have to follow the connect procedure again (resulting in the same spinning icon).

I have no clue why it cant reconnect, I can try at a later time and it might work because sometimes I do have a working WiFi connection.

Here is the screen recording: 22-10-28-13-18-46.mp4 - Google Drive

Also enabled the WiFi debugging and according to this it hangs on trying to make a connection which seems in line with the spinning icon (but there is nothing wrong with my DHCP).

Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) for help.

This forum is focused on developer or beta testing issues.

If you want to, I can send you a Screenshot of my unifi Settings, I am now connected for 2 hours without any issues with FW 3.5.1 and some Unifi Tweaks. I also testet the connectivity via LTE and it works.

Since couple hours no error so its fixed?
Added beta yesterday

Jup, still connected.

So strange. I’ve had a consistent connection all afternoon after reconnecting earlier. I have yet to be accepted in beta, so still on 3.4.9.

Makes me wonder if there was some change on the server side?!

Im connected for a couple hours now without in app errors , how about u?

Bei Nuki für die Smart Lock Beta angemeldet ,freigeschaltet worden .
Manuell Firmware installiert ,keine Probleme mehr mit der neuesten Firmware :grinning:

Same here, I already traced the issue to the lock trying to contact sse* and which seemed unsuccesful causing a reconnect loop with your home wifi. Since a couple of hours the issue is gone. It’s obviously a cloud issue at Nuki side.

1 Like

For me it’s still not keeping a persistent connection. I can see it’s reconnecting often and the connection quality is very poor (around -50 dBm RSSI) even though there is an access point right next to it. The reconnection process ends with the SSE server that can not be reached (you can see this info by pressing 7x on the network header under the WiFi settings). I’m curious if more people are seeing the same.

Came from public release to beta 5.3.2 in hope to get rid off issues with wifi connection, yet it did not resolve… I have Unifi system (no changes in settings) but since last public release my wifi connection keeps disconecting on the lock…

Plus, I am unable to click on the title to enable debug, as the title is not visible? Or am I missing something?

The Apps UI has been reworked with the last release. To enable debug you have to Smart Lock > Settings > Features & Configuration > Tap 7x on the “Features & Configuration” headline.