Nuki 3.0 Pro looses connection despite AP is next to it

I’m having these same issues now. I can reconnect to wifi, with a green connection status. However the connection seems to be lost shortly after. Moved an AP to right beside the lock but there has been no improvement.

This is a beta test forum. We’re happy if you want to contribute, but you have to leave at least some informations. Therefore please mention in your post at least how your wifi infrastructure looks like.

Which router(s) / access points do you use?
Is your WIFI access point also your internet router? If no, which product do you use?
Which internet provider do use?
Have you tried putting the Smart Lock in a guest wifi as described here?

Thank you!

Okay then:

TP-Link Deco M5 here, 4 units total. Used as main network router. Local ISP via dedicated 60GHz link, 500/500Mbps.

Working setup with 3.3.5: Smart Lock connected to main SSID, mesh allowed.

Issues begun just after update to 3.4.9. Tried so far:

  1. Disable mesh for Smart Lock, set preferred mode to 2.4GHz and isolate to single nearest AP

  2. Move Smart Lock to guest SSID (2.4GHz only)

None of the 1) or 2) helped. I’m able to connect Smart Lock to WiFi, Smart Lock looses connection within few minutes. As far as I understand, 3.3.5 was stable release (no beta) so I’m confused why beta-quality 3.4.9 was installed on my Smart Lock as I never have joined beta-test program.

1 Like

AP: BT Whole Home Wi-FI AC2600 x 6
Router: FitzBox 7530
ISP: Local via fibre 1GB connection

Tried the standard troubleshooting steps. Just activated and connected to a guest network as advised. It reconnected for a few minutes and has now dropped again.

I have only had my device a few weeks, and everything seemed to be working perfectly up until a few days ago. Hence I came looking to see if I could find any info on a recent firmware upgrade or known issue…

Asus aimesh APs
Not a single issue since 2 months with Nuki 3.0 Pro
Updated automatically to 3.4.9 since then WIFI constantly disconnect without being able to reconnect, AP shows log error reason : “d11 RC reserved”

We want to downgrade firmware or an update to rollback the changes you made in 3.4.9 about WIFI improvements.

I have a Google Doorbell wireless, Google Hub, ps5, computers, iphone, android, Gardena,… All devices work like a charm on 2.4 or 5ghz except that Nuki 3.0 Pro 3.4.9 firmware

AP: LANCOM L-1310acn dual Wireless and LW-500
SSID: G3m1n1S3rv3r - IoT (for all IoT-Devices)
Frequenc: 2.4 GHz (Only)
Channels: 1,6,12
Signal strength on the Location: 58-88% (With other IoT devices like shelly, amazon etc.)

The Nuki is initial connected. But then (approx 1-5 Minutes) it will disconnect, then Reconnect, then disconnect and so on. It is neither systematic nor temporally containable. From the outside it seems rather arbitrary. Could be a misfuntion on a possible WiFi power-saving mode or something like that.
If the nuki is connected (Signal strength 25-29% ):

The Client MAC-Adress looks like strange to me. Vendor is CC:CC:CC ?
The WiFi trace on AP shows, that the Nuki initiates a Disconnect.

And FYI: Same constellation, but with FW 3.3.5, every thin was working perfekt. No change on the Infrastructure nor new FW on the APs.

1 Like

Hi there, I have a Nuki 3.0 Pro and since the FW Update it loses the Connection to my Unifi Access Point. It worked perfectly for six months, the update seemed to broke it…


I’d like to thank you all for the informations.

We’ve been able to replicate the problem with the Unifi Access Point.

Most of the other access points mentioned are not within our testing arsenal (and there are 1000s of other combinations out there) for which we rely on your feedback. The latest release has been in beta for quite some time and worked well on the access points we use (including Unifis). Therefore please join the beta and continue to provide us feedback.

We are currently investigating the problems and will have an update in beta soon. If you are not yet in beta, please join the beta program now, so that you are ready to install the next beta release quickly after it is available.

1 Like

I allready send a E-Mail with the Nuki ID on Monday, but did not get any response. How long does it take to add the device into beta program? Do i get informed or?

To eliminate my AP, I have enabled WiFi on my FRITZ!Box 7530. I created a 2.4GHz SSID just for the Nuki, and am getting the exact same behaviour. Connects for a few minutes, drops, and fails to reconnect.

TBH, I’m not really convinced that I should have to join a beta program to resolve a core issue where the device is just not functioning correctly.

Typically joining such a program means accepting limited support, which does not seem acceptable in this case.


I will join the Beta and keep you posted. :slight_smile:

1 Like

Of course nobody has to join a beta program. As you can not downgrade a Nuki (and therefore not easily move from a beta firmware back to the last release) and it is a security critical device, some resistance is understandable and normal.

It’s up to you. You can just wait for the next release. If you participate in the beta and provide feedback the likeliness is higher that there is a change or fix included though (and you will have earlier access to it).

Btw: The release was tested with several FRITZ!Boxes and worked flawlessly with them.

Is it possible to join beta program to get a fast fix and then leave it while keeping the beta until the next release ?

My short experience with Nuki resulting in the first automatic update that broke totally what I needed and spent for the Pro version makes me unconfident about your next updates, especially the beta ones.

And I do not want to keep a broken device for 6 months, or more…

Yes. If you exit the beta program after installing a beta fw, the firmware remains but you won’t get any further betas offered or installed (if auto-update is enabled) any more.

I have the same WIFI error with my Nuki 3.0 Pro and my Fritz!Box 7590 AX !
After the Update to 3.4.9 my nuke don’t work - i open a Ticket but i don’t get any possible feedback or i see
FW hoffix on the Nuki …

Why isn’t a hotfix release released immediately - without being in the beta program?
Problem reported on 19.10.2022 and after 8 days no hotfix available, that’s not good for a core error


When there is a fix available it will of course be released as fast as possible.

For me since as far as i notices today, my iphone connects to the server bit no connection from server to my nuki 3.0 iguess this is the same issue u guys are having!? Any solution yet? Thanks!!

1 Like

I just did the beta , it did not solve any of my problems, im at home now and it connects now bq of the Bluetooth connection

Not sure but door sensor death to as far iknow, wont do update, cant do reset