Nuki 3.0 Pro HomeKit Problem

Hello, I am using the Nuki 3.0 Pro and integrated it into Apple HomeKit, I have the following problem, this morning at Apple Home it said “Device is not responding” and the push message that the door was unlocked did not come this morning either. Only when I deactivated WLAN at Nuki did the message arrive late. Otherwise, some push messages from Apple, when the door is opened or locked, do not arrive. If WiFi is off there are no problems, but then I don’t get any messages from Nuki, does anyone have an idea?

1 Like

The problem is already known and the Nuki team is looking into it.

1 Like

Have the same issue. HomePod mini in direct line of sight, but keep getting “Not responding”, causing all automations to fail :cry: Latest firmware installed (3.0.40)

Even with me there is always no answer from Home every day, as you have already written, then the automation does not work, the door is then not locked, sadly you buy the nuki 3.0 Pro and only have trouble … Also the door sensor today indicated door sensor removed, although I haven’t done anything, nothing just works worse. If I switch off WiFi, the Nuki only works with Bluetooth, maybe you should use the bridge, maybe nuki will suit me.

I still have this problem. Has there anything been fixed since November or do I have to live with it?

hello, yes I fixed it, issued WLAN at the castle and bought an external bridge, it’s been working ever since.

Good evening,

Happy to hear that using an external bridge fixes the problem for Patrick but, with all due respect, buying an external bridge isn’t really fixing the root cause… why buy a Nuki 3.0 with integrated wifi and then use a bridge? Is there actually a proper fix to this problem? My Nuki is simply useless via HomeKit, its status is just “not responding”.

It is working for others, so it is not a general problem.

Patricks Smart Lock was affected by other problems (related to his WIFI network), which where the root cause for his problems. There have been WIFI stability improvements in recent Smart Lock firmwares, therefore the issue might have gone away for him as well.

The Smart Lock uses HomeKit via BLE. Which means that you have to have a Home Hub somewhere in the same room if you want to have reliable HomeKit operation.

Good evening Juergen,

Thanks for your feedback… it wasn’t clear to me that to use HomeKit you needed a direct Bluetooth connection, so thanks for clarifying that. And, yes, it’s working now :slight_smile:

Having said that, why is this? Why not integrate into HomeKit via IP only? I moved to 3.0 to get rid of the bridge but now I need to have HomePod nearby instead… which wasn’t initially planned, so it somehow defeats the purpose.


Considering all the different aspects at play, it was a business decision to stick to HomeKit via BLE for the entire SL3 product range. But we won’t share details of the decision finding process here in the forum.

I also have this exact issue. Each lock has a HomePod mini nearby also. I have 3 in my house.

Is nuki planning to add wifi vs ble and/or thread and matter? Either would fix it.

Thread and matter would fix it without causing too much battery drain like ble, and likely the reason you chose ble.

Either way I’d rather charge my batteries more than not be able to use home app to control the locks, or have to use the nuki app for reliability.

Please use the search function of the forum. There are already topics around Matter.

Hello Jürgen, I just received my Nuki 3.0 Pro 10 days ago, I’m suffering the same issue within homekit. My homepod is in the same room around 6 / 7 meters away from the Smart look. When I’m away from hom, the device is not responding 95% of the times…. This is really annoying…
I’m really surprised for this behaviour… not more than 5 meters and also not responding.
When I was looking for into website shop to by my device, I never seen any advertisement regarding this inconvenience.
I feel really disappointed with this issue, and your only response is that is a manufacturer decision. Under my point of view, this is easy solvable for your side using a firmware upgrade. Is there any plan to solve this issue ???

Hi @Juergen can you please answer me on my previous post please ???

Hi Juergen,

I am coming back on this.
HK was working fine for 2 weeks even if no hub was close to the smart lock (3 pro).
Since 2 days no HK (no response all the time).
I moved a HomePod (first gen) at 1m far to the lock.
Smart lock’s HK works only when the HomePod is used as hub but when my second hub (an Apple TV 4K far from the lock) takes the lead then HK is not working again.
Any advise?
I applied for beta program, hopefully Nuki will come to à HK solution over wifi…

Try the beta and follow this thread iOS 16.2 new architecture issues with HomeKit

Done with no improvement.
No Bluetooth link from the SM and the HomeKit hub.
For info I got 3 hubs (an Apple tv, à HomePod and a HomePod mini).
The Apple TV hub is the active one (not to the Bluetooth field of the SM).

Not sure if you tried it, but rebooting at least the Homepods might help. Maybe also removing and adding the Smart Lock from HomeKit.

Hello @Juergen do you realize that everyone is having the same issues with the conductivity of the Nuki smart lock pro 3.0……

Due to the problems with HomeKit on my 3.0 pro, I just spent €100 more buying a bridge, without need it, and is still working bad.
My Smart lock is always saying, “not responding in HomeKit app”.

I tested all and try it all…… but all is in the same way.
For me, it’s not possible to put my HomePod nearly of my smart lock. I have 1 m away the Smart lock and the bridge. I have around 6 m between the bridge and my HomePod.
I thought that buying the bridge, things will get better…. But unfortunately everything is equal.

All people have the same problems, or connectivity issues with HomeKit, distance between smart lock and HomeKit hubs.
Is anyone in Nuki realizing that this is going to reach everyone in the Forums??? … finally this will cause loss of seals for you.
I’m really encourage it with this situation. I have a very nice Wi-Fi coverage from my AP point to my Nuki bridge, and I hope you do something else to solve this annoying issues….
Can you do something more ??? Please let as know if there is something in the Way ??

No, “everyone” would be thousands of users.

It’s mostly individual problems for which we have our support. We are of course monitoring the most common problems that our users have and are looking into them. Our support is regularly updated with the latest trouble shooting guides.

This forum is focused around developer or beta tester issues. If a problem requires a firmware or App release there are usually beta versions made available and feedback is collected in the repective threads or via PM with the betatesters. Changes are announced when the firmware is available in the respective forum topics.

The biggest problem with 3rd party integrations is that the other manufacturer has its own problems too, which it fixes with updates. Apple is no different. Unfortunately this makes identifying problems much harder as its not always clear what & where the root cause is. Reporting the problem at both ends helps. Unfortunately it often takes much more time and energy to solve such problems (if they can be solved at all).