Not able to pair with Android Wear (V2)

Thanks for the info Gert Jan… I am very dissapointed (again)…

Is there possibility in Android Wear to send an invitation to it? That worked on “normal” android device when I couldn’t paired it to the lock.

Generally to “Nuki”: Maybe stop checking everything all the time and start solving issues with your product… You should buy a few smartwatches and make them working long time ago, especially when someone has given you info that there is obvious problem… I have never had a device with bluetooth, that generally was working and couldn’t be discovered… Nuki has big issue with software for bluetooth. Stop ignore that and fix the product.

I am using Asus Zenwatch 2 to try to pair and it does not work. Any updates?

I use a fossil sport, pairing also not possible. How is the status?

I just bought Fossil Q Explorist Gen 4 (FTW4018).

Pairing is not working and there is no workaround with sending an invitation code as it can be done with smartphones, which are not able to pair…

It is also not working through internet by wifi and bridge…


Sorry for the late reply: We are currently working on a fix for a general issue with direct pairing with Android Wear we found. I will keep you updated on progress as this may solve your problem.

The latest App version is live now

Please retry pairing your Android wear device and leave your feedback here if it helped you in any way or not.

I updated the app in my Fossil, but pairing still was not working.
I decided to uninstall the app from my smartwatch to make fresh install, but and now i am not able to install it again. When i check in Google Play it tells me that it is not compatible with my smartwatch…
So now I can’t use Nuki by watch at all…
Great improvement :stuck_out_tongue:

Also tried it, not working unfortunately

For info, I eventually succeeded in pairing my Motorola 360 2nd gen.
After having updated the Nuki app on the phone and the lock firmware to their latest versions, I removed all precedent smartwatch users in the User Management list of the App (it seems my previous attempts left traces in this list), then started the pairing from my watch, and it went OK.

Wow, after removing smartwatch users from User Management List the nuki app appeared in the Google Play Store on my watch :slight_smile: I just installed it and I will check this afternoon if I can pair it.

BTW this is soooo sad, tha nobody from Nuki answered my problem and the solution comes from another user…

Thanks for the feedback, I will try it this afternoon

Updated the smartlock to the latest 2.5.4 firmware. And it works! Quite fast I must say

I don’t believe, but… it works :smiley:
I paired my watch with the NUKI, it took a few seconds, and it just started working
Sometimes not so fast or I need to repeat the demand to lock\unlock, but it is better than nothing :-]

I can’t get my Smartlock v2.0 nor the Opener getting paired to my Android Wear Device, Fossil Q Explorist Gen3…
However both Nuki devices show up in my Smartwatche’s Bluetooth list of available devices!?
Also when opening the Nuki Android Wear App on my Foosil Gen3 Android Wear Smartwatch it takes 2-4 minutes until the status of my locks get updated on my watch. On my Android Smartphone it works quite straight forward.
I am using also the Nuki Bridge and the Android Smartphone App has version 2.4.2 and Smartlock firmware is on 2.5.4 Opener firmware is 1.1.10!?

So you succeded with another device?
Did you try to send an invite to use on your Oneplus 7 Pro to see if you can operate the devices with it?

Sorry but need to adjust/edit the following statement (Smartphone works but Smartwatch doesn’t:

I can’t get my Smartlock v2.0 nor the Opener getting paired to my Android Wear Device, Fossil Q Explorist Gen3…

I am only using the Oneplus7 as primary device and it works with it straight out-of-the-box.

After installation of Android wear App the above mentioned issues occured with having the pairing being made not possible at all on my Smartwatch.

No invitations sent as primary user was created on the Oneplus 7 Pro.

Ah, sorry for the missunderstanding.
Could you provide a log file from your Nuki App with debug mode enabled (and after that retry again)?


Sure will do shortly, please only check the Android Wear Bluetooth connection entries. Obviously those are also retrieved from the connected Smartphone? Will take 10mins and send it over as described in the provided link…

Is there already a solution for this problem? I have exact the same issue (Ticwatch). Smartwatch does see Nuki when both are in pairing mode but can’t establish Bluetooth pairing with Nuki smartwatch app.

1 Like

I would like to pair my montblanc summit 2 Unfortunately this is not possible. When will we get an update?

Same problem here:

Fossil gen 5 Carlyle HR
Wear OS 2.12
Google Platform Services 19.8.31
Nuki app 2.6.4

Cannot pair with:
Nuki Smart Lock 2.0
Nuki Opener

It correctly requests location permissions (to get access to BT/Wi-Fi) but when pairing it just sits there and never completes.