No more Auto Unlock and Auto Ring to Open since Android 10

Since the Update to Android 10 no more Auto Unlock and no more Auto Ring to Open works. I di not even get Notifications that Auto Unlock is available. Anyone else has this issue? Solution?

Same here on my Oneplus 6T but also it doesn’t work on my wife’s 5T with Android 9 (Pie).

Disabled it all together, because I don’t want to be a beta tester anymore.

Same on my samsung S9 with android 9. So i don’t think the problem is with the android 10 but with the app.
My app is the 2.6.0

See the comments in:

There is a known issue in 2.6.0 for some devices which prevents Auto Unlock from working correctly. A fix for this will be available soon.

According to my observation app is not able to gain a location in background despite the fact that autounlocks map is showing the right location. I also tried to open autonlocks map in front of my entry door and my position was showing correctly but the app was not able to trigger geofence entry action so app manytimes is also not able to gain a position while is running. On android 9 this problem occured once per a month, on android 10 autounlock WORKS once per a week :slight_smile: We have multiple google pixels (2,3) devices in the family and all of them behaves the same. On the iPhone there is a choice of what method should the app use to gain a location (GPS, WIFI scan). On android there is no such a option. App only recognize geofence entry as soon as my phone connect to a home wifi.

@Jano: Did you check the App permissions for the Nuki App?

@MatthiasK: I had the issue bak when AU was enalbed. I was standing in front of my door, had the nuki app opened and it didn’t get myposition (also one time i looked into the map of AU and it showed me the correct position). I am also on Andoird 10.
Currently disabled AU.

@MatthiasK Nuki app has a location and physical activity allowed. Battery optimisation disabled and I am not using any kind of battery savers. Also have enabled a background data in mobile data and wifi section. Today autounlock worked well. It is strange I am not able to reveil a pattern of this behavior or in what conditions it is or not able to gain a right location possition but every time when I open a autounlock settings/map in nuki, there is listed my current location right.

I disabled wifi scanning and bluetooth scaning in location setting to enforce using a gps and mobile signal location method.

Everything set as needed, yes.

This setting normally improves the accuracy of the location we get.

For us to follow up it would be best if you send a log file (with debug mode activated before you retest) to our support team at, so they we can see the differences for when it works and when not.

@MatthiasK I am in touch with support for a five months with not significant results. I am collecting debug logs and sendig them to support. Uptoday I sent a more than 9 debug logs with detailed description when it did not worked. Now I can also attach a three debug logs when it did not work. What I think is that when i am returning to home in same times like from work it many times works well but in not standard times does not. Today I came home with my wife in the morning and autounlock again did not worked. Both phones mine and my wifes did not trigger action of geofence entry. Both are pixel 3 xls.

In my experience many times scanning of wifi caused that my phone shows wrong location. It can be related with common names of wifi sites are used arround and android relates it with annother places like with few km far away hotel. I am also convinced that wifi hotspot in my car also breaks location.

If you want to you can look to debug logs from my device. If you need I can also enable debug logs on my wifes pixel but that phone is same as mine. I will send a few more debug logs to support and from todays morning will be included. I will write to the description my nukiforums id and I will provide link to this thread so you can identify me.

But my version of app is not 2.6.x, it is 2.5.3. So when I try 2.6.x I can report if this version resolved this problem.

Sorry, I did not know that you have been in contact with support for so long. Logs you sent them should come to the developers for recheck anyway and if you are already trying things out based on their suggestions please continue to do so. Best way is to have all information in one place.

I have the same problem. I have installed the Nuki Opener with the Smart Lock , connected them to the Nuki Bridge. unfortunatlly the Auto Unlock dosent work. I’m using Samsung S10 with Android 10. My Nuki App version is 2.6.1 .

Please update your App first. We have fixed some Android 10 compatibility issues with v. 2.6.3.
Note that you may have to recheck the authorizations for the Nuki App after the update.