KeyPad2 unusable

The use of KeyPad2 is useless, I mean 1 out of 10 the opening is instantaneous.

The LEDs keep scrolling for about 30s then they stop and the door does not open.

The log does not show anything, I try again and it opens immediately but sometimes it does it again.

I don’t know if version 1 was better.

On the other hand, Nuki Fob is instantaneous and never fails.

I have the Nuki 3Pro I think it is the keyboard I have tested it on two units this one I can add new prints.

The previous one was faulty and could not add fingerprints it said it had no bluetooth connection.

And with the use of fingerprint is worse fails a lot should put immediately that does not work and let me try again because opening a door with these failures is horrible 3 attempts these 5 min in front without being able to open and use the key.

I have a separate separate keypad and I open it with a door opener I end up using my keypad but I can’t open it if the key is out I will have to connect it to a Fob so it will be instantaneous.

If the Nuki Fob is always instant opening.

It is because the keyPad2 is not working properly but I have had several so it is a failure of the KeyPad2.

Any solution?

I think it is a bluetooth connection issue with the Nuki 3 Pro because the Fob does it correctly.

I show a video and you will see that it does not appear in the history only appears when I open but when the led blinks twice it does not open the door and you do not show it in the history.

Any beta solution?

Why doesn’t it happen with Nuki Fob?


I had several situations with exact the same behaviour. Keypad 2.0 with Lock 3.0 Pro and the lights on the KeyPad 2.0 keeps rolling from left to right and it’s not opening the lock.

Lock and Keypad are checked and they have the latest firmware.

Ideas ?

1 Like

Same for me, the Keypad 2.0 opens the door with the Nuki 3 Pro rarely very fast, mostly very slow or not at all. Have already made 3 times factory reset and set up again and even hung the keypad for a while right next to the lock, because I thought that maybe our door is too heavy.

But it always remains a big coincidence if or when the lock opens.

With the Apple Watch in Bluetooth mode, the door opens instantaneously, even from four meters away, the same with the iPhone.

I really don’t know what to do anymore, it’s really inoperable like that.

1 Like

The problem is the Keypad2 I don’t know if it’s the hard or it needs an improved firmware version, because if I use the Nuki Fob the opening is instantaneous!

But this keyboard is useless, the opening if you open it is very slow even if you use numbers instead of fingerprint.

Even sometimes it doesn’t open, the LEDs blink after waiting and it doesn’t open the door.

1 Like

There is something wrong with your hardware - I would try and get the keypad replaced.

I use a Nuki 2.0 lock, but since the keypad only connects with BT directly to the lock there should be no difference to the 3.0.

The opening sequence is very fast - put the finger on - maybe 2 seconds and the lock starts to spin.

Here a video how it should work:

Therefore please contact our support via the Nuki App (Menu > Help > Contact Customer Support) for more detailed information.

This forum is focused on developer related issues.


Something wrong with the BT connection maybe - to test it:

  • take the keypad out of the mounting
  • hold it close to the lock
  • enter the code

Does it work then?

It is 20cm away, with the keypad2 just above it the same thing happens.

Also when the keyboard flashes, it turns off and does not work, you have to remove the batteries.

It is not a well manufactured product internally fails a lot or send it to me defective.

It clearly is a defective unit - contact the customer support as Jürgen has suggested and get it replaced.

I bought it on October 9 and have not been able to use it yet.

The first one I opened then used deteriorated and blocked when it was open it knocked inside the box, this one I could not link it because I did not have the key of the person who used it.

They sent me another one that was damaged in transport and did not work, I solved it but the fingerprint did not work, it did not recognize any fingerprint and you could not add any.

The next one is this one and it finally works, but it never opens badly 1 of each time the door opens and it turns off every x time I have to remove the batteries and it works again as in the video.

After 3 months today I receive the replacement today I open the box and it is not a Keyoad2 :man_facepalming:

Either I have bad luck or …

I have lost hope I have sent another mail again.

Someday I will be able to have my KeyPad 2 that I paid for on October 9!

I have now installed the beta versions for both the Smart Lock and the keypad - this did not bring any improvement at first.

Smart Lock 3.0 Pro: BETA Firmware: 3.5.5
Keypad 2.0: BETA Firmware: 2.1

So I reset the Smart Lock and the Keypad, but this time I turned off the internal Wifi of the Smart Lock.

It has worked the last few times now, but I will look again until tomorrow and see if it is really better now.

If it stays like this, I will turn on the internal wifi again and see how it goes then.

I will then write here again how it went.

Same issue here, heavily disappointed.
Just installed Keypad 2 around 3m distance to Opener. Itdoes not work.

today, with all the updates, i can tell you:
installed 5 fingers from 5 people.

90% works
10% not even 1 person work, we all try it - no chance.

after a couple of hours waiting, it works again.

the keypad2 is just 50cm away from nuki 3.0.

i hope that one day a version will be released where it is just super super stable with absolutely 0 issues here.

With more updates it has improved but it crashes a lot or takes a long time to open.

You use the Fod and it is instantaneous.

When it crashes remove the batteries and it will work again, it has happened to me several times.

i didn’t need the batteries, just realized that it worked hours later again.

Same here with Nuki Pro 3.0 (connected via Bridge) and Keypad 2.0 meaning using fingerprint either doesn’t work at all or takes ages to open the door lock which is around 30cm of distance. Really annoying!

Wondering why a Nuki Smart Lock 2.0 which keypad 2.0, connected via same bridge, opens quickly and with any fingerprint. Same distance from keypad to lock!?

Same here. I had old keypad before and it worked 90% of the time. The new keypad 2.0 with the same installation place works maybe 10-15% of the time. I have it on the latest FW but It doesnt help.

I just think Nuki pushes these way too soon without proper testing, im guessing it will get better with time, but for now its just useless. I rewert to my old key or I open the door via the app.

I just sent a customer support ticket, but it will be a lengthy battle now :slight_smile:

There are 10.000s of KeyPad 2.0s actively in use. If it were a general problem, there would be many more complaints. As mentioned already above, if you have problems with your device, please contact customer support.

This is a developer and beta tester forum. Thank you!

No!!! I am no longer complaining that it is very different and that will make the 10,000.

I have been sent several replacements and they all have the same faults.

It is true that the last one goes a little just a little better but it is the worst accessory, moreover useless of the catalog.

Every time I go to open it they laugh at me, my brother who lives next door.

You end up opening it before with the key, they go in and I keep waiting to see the LEDs moving from one side to the other waiting for it to lock or not to open but I never wait for it to open.

The Fod is instant!

It is horrible this keyboard and people do not complain, because first talk to the technical service is a chaos they do not make you or case I bought it in October 2022 and the replacement that I use I received a month ago.

That’s why there are no comments from more people.
I have an independent keypad and I will modify the Fod so that the keypad that has a relay acts on the push button because it is very fast and practical.

The KeyPad 2 is a useless accessory.

It is also true that they made an update that improved so they should focus on a better firmware or as if it were a Fod.