I can't connect to my mqtt broker with the Nuki

Can I write here also in German? I wrote this text with a translation program, I apologize. Now to my problem:
Unfortunately I can’t connect to my mqtt broker with the Nuki on my home network. It keeps rejecting the connection and I am supposed to try again. In the log of the broker it says invalid Authorization (see Picture), although name and password were entered correctly of course.
If I want to connect the broker and the Nuki to a foreign network, it works immediately.
The difference between these networks is actually only the ip4 network addresses configuration and that of course in my home network very many devices are connected. But I have no other device running on the mqtt 1883 port.
Home network 172.20.0…
foreign network 192.168.1…
Can you explain this ?

Other important findings:
According to the log in mqtt broker, username and password is not sent in my home network. This is the reason for the Invalid Authorization message. In the foreign network where the mqtt data arrives from the Nuki I see behind nuki/…Connected false username and password in plain text in the log.
So I set up the mqtt broker without login name and password. Now it seems to connect shortly, however in the Nuki app the same error message comes up and mqtt can’t be saved in the app after setup.

Translated with DeepL Translate: The world's most accurate translator (free version)

It is a pity that no developer comments on this, although other users here in the forum also write about this problem. If I at least knew if it was worth the work to change the IP range at home.

There is one UI glitch in the current implementation which might be the reason for your problems:

You will have to fill in the password every time you change something on the MQTT settings page in the Nuki App. If you leave the password empty on this page (leaving the “optional” text in the password field) will set an empty password and the Smart Lock will attempt to connect without password afterwards.

if I set the broker to connect without a password and leave the password field empty in the nuki app, it only connects for one second and disconnects again immediately with the same error message. In the broker, the first data also come in, then the connection breaks.
Unfortunately you do not address my suspicion that there is a problem with the network configuration. Because the same broker connects without problems when I use a network in an IP range 192.168 with the same Nuki. Other users seem to have the same problem, that can’t be a coincidence.

1 Like

Is the UI glitch problem still present? Unfortunately, I still cannot use the mqtt connection.

The mqtt connection problem in the private network with the ip: 172.20… has been fixed in the current beta version 3.8.2. It really took a long time. Thanks anyway. :+1:


Sounds really promising. A good reason to join the beta program.

Btw. this has also been fixed/improved with 3.8.2. Now a new password is only required when changing the username or sever, but not when just turning MQTT or any of it’s options on or off.