GDX5 Intercom integration

I have a GDX 5 intercom. Similar in appearance to GDX 1/3, but different internally. I’m really keen to test out the nuki opener with it, but having no luck. I’ll keep my fingers crossed.

If anyone has any suggestions or has tried previously, please let me know, otherwise I’ll just give up.

1 Like

GDX 1/3 is a 7 wire analogue system.
Your GDX 5 is a 4 wire bus based system (most likely), so completely different.

The “non standard intercom” means that there is no voltage on the cables or that the voltage has the wrong polarity. We can’t give you any suggestions on how to cable it, as long as nobody has properly measured this system (multimeter, oscilloscope).

Many thanks for the reply. I’m gradually giving up hope.

Do you think there is “any” or “no” point in trying different combinations of connecting the nuki system?

I concluded the wiring is 1. Speech in (microphone) 2. Speech out (speaker) 3. 0v 4. 12v

I have the black and red nuki cable connected to 1 and 2, and nuki app set to generic, but no luck. If you say keep trying, I likely will.

It appears such a simple solution for keyless entry, but obviously technology has hindered itself.

Can you please try to remove the cable to 1 from the intercom and check if the door still opens when you press the button at your end and if it still rings when you push ring at the entrance panel?

Same with the cable that goes into 2.

Let me know what happens if you disconnect them.

if I disconnect 1. then there is no ring. the ‘mute’ button lights up. I cannot open the door either.

if I disconnect 2. then the handset does nothing, no ring nor open notification.

in order to open the door, the handset needs to be ‘activated’ by someone ringing AND the handset should be lifted.

Not good. With the need for activation AND lifting the handset, the Opener is basically lost and can’t do anything at all, no matter how you wire it.

The only thing that comes to my mind, that you could try is to connect RED to 1 and BLACK to 3 and reconfigure it as Brand Generic and Model Bus (Generic). Before you start the configuration wizard ask somebody to ring the bell (= activate your system).
Then you start the “training” step (which asks you to push the actuator button on your intercom).
You pick up the phone and press on enter.
Complete all other steps of the wizard by just answering with yes (they will all fail, but if you are lucky the open door command was properly recorded and the Opener can open the door).

If not, i don’t see any hope for your setup.

Hi. Sorry it’s taken a while to give it another try.
I’m a step forward, albeit a little step!

Wired up as you instructed. The Nuki device recognised that there is a signal, and lets me proceed to the configure step. When it asks me to press the “open” button on the intercom, the nuki opener seems to reset itself, disconnecting it from the bridge and therefore sending an error to my app.

Sorry to revive an old thread @galen but I also have the GDX5 Intercom I’d love to “smarten up” and just wondered if you ever had any luck getting the Nuki Opener to work with it?

Also @Juergen has there been any update or progress on compatibility with the GDX5 or similar types of intercom?

Hi, another year on and same question. Anyone had any joy connecting a GDX5 intercom to the Nuki opener?

Thanks and sorry if I have posted this in the wrong place

Wish i had had success. I emailed the manufacturer who stated “this intercom was not designed with this in mind”. Id love to get it working, even just basic functionality.

I have an oscillator. But no idea what im doing with it.

Klevio (nuki competitor) states they have a working solution, but they would need one of their engineers to visit site, london only. I’m edinburgh.

1 Like

Looks like their workaround requires you to call up to the flat through the intercom before using the app to unlock.

A GDX5 is even used as the example in their YouTube video “Klevio Academy: Intercom Call Up Limitations”

Also have an opener and just spent the day trying lots of things. I don’t have the same behaviour as as @galen, for me I get to the enable door actuator but can’t actually get it to detect anything, even after ringing and opening. It just keeps with the ‘loading’ spinner. I wish we had greater debug abilities I would like up see what was recorded and maybe play back to see if it’s picking up anything.

If anyone has experience with this kind of stuff I’m happy to try things, or maybe even do a fun zoom debugging session.

I don’t know how these digital systems work, but it’s interesting that I can audibly hear the intercom send touch tones. Two beepd when you pickup the phone, and a few more when you press enter.

Based on my limited knowledge, I still feel like this is doable. They’re effectively just touch tone noises and I’m sure that kind of thing has been emulated on other systems.

I actually think this might be a bug in the Android app rather than an underlying incompatibility.

The loading spinner keeps going indefinitely, even though Nuki Opener stops double flashing (to signify learning mode) after 30 seconds.

What’s more interesting, if I switch away from the app and switch back (within a few seconds), the app reports a timeout even though I can see Nuki Opener double flashing and it obviously has not timed out.

Perhaps I’ll try and borrow an IOS device and try.

edit: Nevermind, I can see @galen is on IOS. I wonder if we’re experiencing the same issue with different symptoms due to app differences between OS.

As a side note, needing to lift the handset is definitely not a deal breaker in my eyes as @Juergen suggests. My presumption is based upon the following:

  1. In “Post-call” mode, lifting the handset results in some audible touch tone beeps. There is some digital signal being sent by the GDX5 when you lift the handset, which should be recordable
  2. The GDX5 supports 1 additional slave unit, which are connected to terminals 1, 2, 3, 4. Logically, that means a slave can open the door on a master without needing the master’s handset to be picked up. All of this can be actuated by emulating the touch tone signals on (presumably) Terminal 1.

I’m hoping we just need the right software or configuration to be able to do this, and clearly Klevio can do it but Nuki need to provide us with some more advanced advice and tools to debug!!

I’ve tried both apple and android devices. I’m now on android. I got to the timeout message too, but couldn’t get it to recognise the call up.

Could you send me an image of how you have wired it?

I’m very determined, and if klevio can do it, I’m sure nuki can manage it.

Currently Red on 1, Black on 3, latest opener firmware, and I can reproduce the above.

But I tried almost every feasible combination I could think of, including that suggested in the setup (1 as B+, 3 as B-) and one suggested for a Fermax ( which also requires a pre-call. These yielded the same behaviour or just ‘invalid configuration’ screens, nothing promising yet.

Some observations in my full day of experimentation:

  • I was able to reproduce the Nuki disconnecting like you on my unit by “cheating”. I connected a configuration that worked, then swapped it after I got to the next screen. This seemed to cause the Nuki to disconnect like with yours

  • Connecting Red on 2 should allow Nuki to read the Speaker output, and I thought maybe the signals are being sent here since 1 didn’t work. However the Nuki app takes you to the ‘invalid configuration’ screen if you do this. There is possibly something up with the voltage of this line.

  • I can force my way passed the training screen by disconnecting Red on 1 during training (without a pre-call) then reconnecting. This is obviously just mistraining, but disconnecting Red might be a way to force Nuki Opener to stop recording assuming that the recording has worked (doubtful).

  • Connecting Red on 1 causes the Privacy (mute) button to be disabled. According to GDX5 docs, when connecting a slave unit you’re supposed to use the EXT PRIV Terminal - presumably to synchronise mute between both units. The fact that Privacy is disabling might mean GDX5 handset thinks Nuki is a Slave - perhaps this is messing with detection somehow?

  • I’ve read a whole bunch of GDX5 documentation at this point and can’t understand what the blocker is

Anyway, at this point I’m all out of ideas. Ideally I’d like a way to actually debug what’s going on - would be great to confirm that Terminal 1 is indeed where signals are sent through.

For ring detection over speaker wire (red), the opener has to be configurate from remote, where a nuki employee activates this. But I think there are more incompatible things with your intercom than just this.

Good news everyone! I’ve managed to get Nuki Opener working with my GDX-5.


  1. As with the Klevio solution and other intercoms on this forum, you will have to Dial your property first before the “Open” function works. This will NOT work without dialling first. Features such as Ring-to-Open work perfectly. My personal preference is enabling notifications and just using the ‘Open’ notification action on my Android phone.
  2. Implicit Ring Suppression: The built in ring of the intercom will be disabled. You’ll have to rely on the Nuki Opener itself and phone notifications for your doorbell.
  3. The Opener ring will chime multiple times after opening, because of the way the hack works.
  4. Guests who use the intercom to ring, won’t hear a dialling noise anymore on the other end and instead will see “CALL ANSWERED”.
  5. You will need to do some soldering. I had never soldered in my life before(!), but bought a £15 kit from amazon and managed to do it with help from YouTube. It’s not hard however there are not nice solder points to do this, so you have to be careful not to touch any other contact points.
  6. I have a very old model of the GDX-23121 (from 2005 i think), which has LEDs seperate from the buttons. @galen’s looks to be from 2016. This makes the soldering a bit easier for me, however it should be possible in the new models too. Someone on this thread will have to test. I recommend you get a friend to hold the cables in place before soldering to see that it works.

How it works

  • I keep the phone on the hook all the time, so the handset doesn’t have to be lifted anymore. This is done by disabling the hangup switch
  • I use Nuki’s hidden Analog mode, which is enabled by developer support. Instead of trying to use the Opener to send and recieve Digital Signals from Terminals 1/2, we read and send signals directly to the PCB. For ring detection, we use the Green light which activates when someone rings. For Opening, we send a signal directly to the “Enter” button on the Intercom. Because the Green light bleeps repeatedly when opening, this does cause some additional chimes from the Nuki Opener.

Step 1: Enable Analog Mode by contacting Nuki support

Note: It is advisable to do this on a Weekday so Nuki support can respond quickly - e.g. Monday am

  1. Set your Opener Admin pin to 1234
  2. Go to the Manage Users screen, and invite a new user, which will give you an invite link like this Note, this invite code only lasts 48 hours so I recommend you do this early on during the working week.

Contact with the following message:

Step 2: Remove the hang up button

This whole thing works by keeping the phone on the hook all the time. This enables the “Open” button to work without having to lift the handset.

Use a small flathead screwdriver (I used the one that came with the Nuki Opener) to pry the plastic hangup button up from the prongs on either side. This should be really easy, and you can always reinstall it if you want to return it to previous behaviour.


Step 3: Delay Settings

In the Nuki app, i have my settings as follows:

  • Opening duration: 3 seconds
  • Opening delay: 1 second

I think you should be able to reduce these, but they work for me so I didn’t bother tweaking them.

Step 4: Wiring (including soldering)

Summary of wiring

Nuki cable Terminal/Component Description
Purple Terminal 3 This is the ground wire for Ring detection
Black Terminal 3 This is the ground wire for Open simulation
Red LED1/LED1B: Solder to G pin.


TR2: Solder to bottom-pin
This is for Ring detection. We use the Green LED for Ring detection, and you’ll need to solder to the Pin. For my older GDX model, I used a nearby connected pin rather than the LED itself (bottom of TR2) because this was an easier solder point, but the principle is the same.
Blue SW3: Solder to top-right pin This is for simulating the “Enter” button. On my older GDX model, I didn’t even need to solder this because there was a Pin-hole ready for me to use :slight_smile:

After soldering

My predicted image for newer models

Based on @galen’s image, here is where i think you should solder on newer models. Like i said above, I recommend you test this by holding the contacts in place manually with a friend first before soldering!

And that’s it! Good look everyone. I just got this all working today and have tested myself but will see how things go with time.

Hi, sorry to revive this. Has anyone else tried danc’s solution? I have the exact same model and am just on the fence whether I should purchase Nuki Opener for this. It does seems straightforward.