Enabling debug mode w/ beta firmware

Hi there,

our SL3P arrived today. I got the MQTT beta firmware installed, but I fail to activate the debug mode using the Android app as the header documented at How to enable debug mode on a Nuki Smart Lock or Nuki Opener does not seem to exist for my version of the Android app (v2023.2.1):

Any ideas?

Tap 7x on the “Features & Configuration” headline.

That worked, thanks! (Although I was certain to have tried that before :wink: )

Edit: The lock is also already connecting via MQTT, very nice!

1 Like

Is the same procedure on the iPhoene Nuki APP?
It looks it is not working on my iPhone.


Yes. Works the same for both Apps.

Hi JĂĽrgen,

I tried to switch on the debug mode by tap 7x “Features & Configuration” headline, but nothing happend.
Nuki Smart Lock Pro 3, beta firmware 3.5.8, iPhone 12Pro, Nuki App version 2023.2.1 (2353).
Is it necesary to enable debug mode access as described in documented “How to enable debug mode on a Nuki Smart Lock or Nuki Opener” ? There is no “Help” - “Error log” section in the actual Nuki APP.

How does one know if the debug mode has been set correctly?

When trying this on my side with 3.8.4 and latest iOS App got a popup that debug mode is getting enabled. But - as said above - no idea where to lookup the logs.