Can't update firmware - can't get into Maintenance mode

Hi all,

I just got a brand new Nuki 2.0. It’s running version 2.4.4 and says there’s a firmware update to 2.4.5. Installation should be very easy. The download of the firmware and transfer to the Nuki smart lock succeeds. It’s the maintenance mode that I can’t get into.

When I keep the button on the lock pressed and hit “Next” on the screen, not the upper part of the lock starts blinking (maintenance mode), but the entire circle starts flashing. Then it locks the door and then opens the door while I’m keeping the button pressed. In the activity log it says Position detection . Whatever I try, I can’t get it into Maintenance mode .

Does anyone have a suggestion? Thanks!



Try to replace the batteries with new ones.

Thanks for your response. I replaced the (already new) batteries with another set of brand new batteries. At 10:53 today I tried again. Same problem persists. See attached screenshots of firmware error and activity log. In the activity log you can see that keeping the button pressed triggers the “Position detection” instead of “Maintenance mode”.

Please advice, thanks!

I’m only allowed 1 image per post, so here’s another post :slight_smile:

I finally got the firmware upgrade to work. The problem was that the 2-steps wizard missed one very important note. The wizard tells you to press the button on the lock, then click the “Next” button and keep the button pressed until the top segment of the LED ring is constantly glowing.

This turns out not to be completely true. You have to push and hold the button, WAIT FOR THE LED RING TO GLOW ENTIRELY, and only then click the “Next” button in the App. Keep the button pressed until the top segment of the LED ring is glowing and now the smart lock gets into maintenance mode.

Good to hear it worked now for you!

Though the steps you described should make no difference at all (i.e. you should be able to get to maintenance mode with pressing “Next” earlier in the App). I will try to reproduce this anyhow.

Did you have similar problems with initial pairing of the Smart Lock in the Nuki App or did that just work fine?

Hi, same thing happened for me: got my Nuki 2.0 yesterday. Installed it, saw the message about the firmware update and tried multiple times to update.

Every time the lock went into ‘position detection’ mode. Tried again twice this morning: same problem.

Googled ‘nuki maintenance mode’, found this post, followed this procedure (press next only when ring is glowing) —> immediate success.

@MatthiasK I did not have any problem setting up Nuki. Installation and configuration (bridige/wifi, bluetooth, pairing, all of it :slight_smile: ) went great without any hickup. This firmware update was the only issue I had.

@smerkx I’m glad this solved the issue for you as well!

1 Like

And just to confirm: I had no problems with initial pairing of the Smart Lock in the Nuki App, that just worked fine.

Although I did have a similar problem when pairing the Key Fob: I had to press back/next in the app while pressing the button on the Fob. As if the first press on next was too soon and the Fob wasn’t quite ready…

So it seamed I had the same problem … turned out I just didn’t press the button firmly enough … figured it out when pressing the button and not pressing it issued the same result … position detection … so for me, just pressing that damm button firmly and holding it like a man :slight_smile: did the trick :))

1 Like

I have the same problem if I push the button Nuki goes in to position detection

Same for me, had to try over 10 times until it worked out…

It’s true!!! I had the same problem and the solution was press firmly the burton. Like a man :joy::rofl::joy::rofl:. Thanks Amon.

1 Like

Had the same issue just now. Not only I had to re-try downloading and transferring the firmware maybe 10 times, I then couldn’t enter the maintenance mode until I googled it. Turns out, I had to press and hold the button until the full circle lid up, then press next and then keep holding it until only the top part turned on. Very frustrating, why does it have to be so difficult?

Also, I think the lock should be automatically updated through the Bridge, with just one press of a button. Why not?

1 Like