Cannot get App to connect with Bridge

Hi Ivo,

I maid some progress but I still cannot activate the Nuki Web Account…

The solution to my problems was:
1: Get the Beta version of the Nuki App: Go to Play Store, lookup your installed Nuki App and look for something like ‘Become beta tester’ This will download the newest version of the App to you phone
2: Factory reset your Smart Lock, this is not the same as deleting it from the registerd locks in the Nuki App. You realy need to find the Reset Factory option.
3: Factory reset your bridge
4: Verify that your Nuki Smart lock app is the (beta) version: revisit the Play store and once again search for the nuki app. The title should now show Nuki Smart Lock (Beta)
5: Open the App
6: Setup the Smart Lock
7: Setup the Bridge and make the connection with the Smart Lock. This time it worked for me.
8: the final page shows a Server Icon connected to a Bridge icon connected to the smart lock icon.
9: the only option I now see is in the right upper corner. Pressing that check icon, I get the message ‘Rebooting bridge’ and all the above done action seem to get deleted again…

Thanks Geert for your folluwup, after over a week customer support indeed told me to try the beta version. I did download that and I could indeed give in my wifi password and the bridge is connected to wifi. However the connection between the bridge and lock still wont work. It gives fault code 506.
Answer of nuki support: it can last 24h for the connection to be made.
Ivo

I also had that error message. But after resetting both, lock and bridge to factory setting and setting up both again, solved that problem.

I am not sure what you mean with 24h for the connection to be made? What does that mean?

Hi Geert, i do not know. Customer support told me that. They said it could last up to 24h before it works in the beta version.
I knowbhow to reset the lock. How do you reset the bridge?
You are better then the support team!
Ivo

If I am not mistaken, to factory reset the bridge is only possible after the initial setup succeed. If not you will not be able to find the factory reset option.
First press Manage Bridge


You will then see
After that process ends you will see

Then press the bridge Icon and that will lead you to

And there you find the factory reset option.

If you press the yellow plus on the this screen

you can add your smart lock.

But here I do not know how to continue. Pressing the yellow check mark (top right) cause the bridge to reboot.’

Followed by

(This screen does not allways appear. Not sure when it does and when it does not).

After that all you did, seems to get lost and you can once again start with the first screen shown at the top of this message. I just cannot get the bridge to remember the lock!

After reconnecting my phone to the bridge and the bridge to the smart lock as described above, and after the home page is shown againScreenshot_20190702-074721_Nuki

Pressing the smart lock and activating the Connection Status option

I see the following.

No connection between the bridge and the smart lock!

Very frustrating! If you figure out how to continue please let me know!

This afternoon I will be receiving my AirBnb guests and I would really appreciate it if the lock works as it should!

I decided to try things a little differently:
1: Factory Reset Smart Lock
2: Factory Reset Bridge
3: Start with setting up the Bridge first
4: Setup the Smart Lock, at the end of this process the app will ask if you want to setup the bridge…(I thought I already did that, but okay lets do it again)
And than all the sudden, everything seems to work!

While doing the setup in a different way, I did notice a small message appearing that a software update was ready to be installed. I am not sure if that was a Nuki update or an update for another app. Anyway, it all seems to work now. I can even activate Nuki Web! Finally!

A not set up Bridge has the same status as a reset one, but yes, you need to aceess bridge management to reset it.

What support wanted to tell you with the “24 hours” is that the status info screen can take some time to be updated (as the info there tells you).
The update of the connected Smart Locks to our server from the bridge itself can take some seconds minutes (at worst).
So there is still the possibility you can’t see the correct status, while it is in fact already connected.

If you click somewhere on that info screeen you get to the connection status where you can try to manually update the screen.

With that you should also see the possibility to connect immediatly (and in general it is not needed).

So when you reversed the order of installation you just “waited longer” for the Bridge push in fact. :wink:


Regading Bridge HTTP-API: I am not sure what your initial idea was to post in this section. Do you have any questions on that topic or things you need help on there, as this is the purpose of this forum:

A developer forum not a Nuki support forum.

https://developer.nuki.io/guidelines

Thank you very much Geert! Resetting the lock to factory settings did the trick for me. Customer support was most unhelpful and did not gave useful information.
I think the last time I was so frustrated with a piece of technology was over 20years ago with my dial in modem. I hope it keeps running now.
Ivo

Hello Nuki Community!

I got my Nuki 2.0 Combo today and have to report the following issues.

  1. The provided batteries were dead… dead as they can be. I measured between 0.4V to 0.05V on all the 4 batteries. After i inserted “fresh” batteries the lock came to life. Seems like i got one of the “old” batches.

  2. I had to reset the Lock completely because I couldn’t get past the step with the “do you have a lever or a knob” question. It always told me that there was a Bluetooth problem with error code FE. But after I had factory reset the lock the installation process went pretty smoothly.

  3. Now to the actual problem: I cant connect to the provided Nuki Bridge via my Smartphone (One Plus 6T Android 9). I only come so far to try to connect to the bridge, it then says “Connecting to bridge” but after about 10-15 seconds it just shows the message that the Bridge has to be in maintenance mode.
    The bridge is plugged into the wall connector and the LED flashes regularly every second.

I tried installing the newest beta version (2.2.2) but the problem still persists.

Since i cant reset the bridge withouth an initial working setup process i cant try that - so what are my options?

Have you tried calling Nuki Support? I did so yesterday morning and was called back yesterday afternoon. All my problems got solved.

Same problems here! My phone is OnePlus 6 with Android 9. No way to connect the bridge. Very frustrating

Is the bridge visible in your bluetooth device list? Go to your phone’s settings, conections, bluetooth and look for two Noki devices. If you do not see them, it might be a bluetooth problem.

Yeah is visible and when I plug in the socket during discovery phase, the message on my device changed. Apparently the app see the bridge but something fails.

If I were you, I would try it with another phone. And give Nuki Support a call. The person answering the phone will not be able to help you, but you will be called back by somebody who can.

1 Like

@LordSimal Have you tried making a connection through the Status Connection page (see picture above)? On that page you see the ‘Try to connect’ option.

@Geert I can open the “Status Connection Page” via following steps.

  1. Open Nuki app
  2. Click on the already setup Nuki lock
  3. A small window pops up from the bottom. There i click on Settings on the top right.
  4. In the middle of the new Screen there is a “Connection Status” element. Clicked on that.
  5. Then i can see a circle with my smartphone having a connection to the “Server” and my already setup Smartlock. There is no connection between Server, Bridge and my Smart Lock (obviously). Here i click on the Bridge
  6. Here i see pretty much exactly the same page as “Stephan NUKI” has shown above.
  7. No matter if i click on “Try to connect” or “Bridge” i get to the “default” Bridge setup page (same as if i go through manage devices => bridge) where it tries to connect to the bridge without success.

So no, that “other way” doesn’t work for me.

@altrdev already privately contacted me and said that there is a “specific” problem with the One Plus 6T.

I now try to setup my old LG G6 and setup the Bridge via that smartphone.

@altrdev
Here my findings with the newly setup LG G6 (Android 8):

  • I basically get the same behaviour as with the One Plus 6T
  • I can see the Nuki Bridge as a Bluetooth Device in my Bluetooth settings. I also can connect to it (shows up as paired device), but that still doesn’t help with continuing the Bridge Setup process.

I tried that last step again on my One Plus 6T and i do indeed can “connect” to it via the Android Bluetooth Settings Page to get a “paired” status but it still doesnt work in the setup process for the bridge.

Installed App Version: 2.2.2

So now i can only wait till the newer beta version shows up on one of my phones (i am already in the beta programm, or at least the playstore tells me so)

Here is a screenshot after i clicked on the “Try to connect” Element on the Connection Status Page:

@altrdev

I just got the 2.2.3 Update and “successfully” could setup the Bridge with my One Plus 6T… but at first only with my Lock, not with my WLAN

The Bridge had problems detecting my (or any other) WLAN station. I waited for over 5 minutes but no networks were appearing. Only after i reset the Bridge to factory settings i could connect the bridge to my WLAN.

I checked the firmware version before and after the factory reset because i thought probably there had been an update, but both times it was 2.1.37

So i have no idea what the problem was here.

Only thing i can tell is that i had to reset both lock and bridge before i could setup them successfully.

Thanks for the help though :smiley:

EDIT:

Sorry, but there is still a problem with the bridge.

I first thought that the setup process went smoothly.
But after about 10min i checked the “Connection Status” page of my Lock and it showed me, that there was no connection bettwen Server, Bridge and my Lock.

So i tried to reset the Bridge again and go through the same steps as before but now i cant connect to my WLAN because the App doesn’t show me my Access Point.

I tried to manually connect to it but it just brings me the following notice:

EDIT2:

Fixed that problem after rebooting AKA unplugging and plugging back in the bridge.
Also i had to Click the “Try to connect” on the “Connection Status” after i had done the setup process again so the bridge shows as “connected device” in the Nuki App.

1 Like

Sorry for the late reply as your topic seems to have been missed during my vacation:

Any more problems on your side with the latest version?

No, after the process explained above everything works rather smoothly.

I just recognised something else but this doesn’t have to do anything with this problem.

1 Like

hallo , ich habe gleiche Probleme

es hat jetzt auch nicht geholfen, nuki bridge blinkt jetzt seit 4 tagen und kann kein wlan finden ich sende dir bilder ,Ich habe versucht, das Internet-Passwort manuell einzugeben. Fehlercode Fehler 10