Cannot get App to connect with Bridge

I am new to the Nuki products. I just received my Smart Lock 2.0 and Bridge yesterday. Contrairy to youtube movies showing that the installation only requires minutes, I have now spend hours trying to get things work. Unfortunately I have not succeeded yet. Problems started with the batteries deliverd with the Smart Lock. The are totally dead. I could only get the lock working by replacing the batteries with new ones.
The second problem is the installation of the bridge. I have tried everything and followed the (conflicting) instructions many times.
When I unplug the Bridge and replug it, it starts blinking immediately. But my Nuki App (after searching for a while) informs me that, in order to get the bridge in maintenance mode, I need to unplug the Bridge, and keep the button pressed while inserting the bridge into the socket and keep it pressed until the light on the bridge turns on. After pressing Continue on the app, it says that it is trying to connect , but the again it tells me that it cannot find a bridge in maintenance mode.

I have done this20+ times, and start feeling like an idiot, expecting an other outcome…

I have read thing about updating firmware but have no clue what firmware is installed nor how to upgrade. The app does not show any ‘Upgrade Firmware’ options.

I have even installed the Nuki Bridge App. This does seem to work, I see a Server icon and an Android Bridge icon and a Smart Lock icon, all three with a green dot. But I have no clue what this does for me.

Returning to the Nuki app, selecting the Nuki Bridge to be ‘maintaned’, selecting ‘Maintain Bridge’ brings me back to the problem as described above. It cannot find a bridge in maintenance mode. Meanwhile the bridge in the socket is flashing continuosly (is that maintenance mode of normal operation mode?).

My phone is a Samsung Galaxy S8 (not sure if this is relevant).

My phone is set to the Dutch language so some of the menu options and descriptions are translated by my and therefore might be different than what you see on your phone.

Please help!

Hello, I am experiencing the same problem. The configuration of my smart lock 2.0 went well but I can’t get the nuki bridge to be discovered by the app.

I also have a Samsung S8 with Android 7.0.
The version of the Nuki app is the 2.2.0

My Nuki bridge id starts with 17 with a date written next to it : 09/2019

Hi Vincent, how did you manage to get a bridge id?

What I called the bridge ID is the Nuki ID written on the back of the device.

In the meantime, I have seen on the forum a beta version of the app (V2.2.1) is available and should correct the bug we are experiencing.

But I can’t find where to download the apk.

Cheers

I think a read something about the need to register yourself to become a beta tester somewhere.

To become a beta tester of the Nuki Android App go to the Nuki App in the Google Play Store and choose “Become a beta tester”.

Hi Vincent,

I also so the message about the 2.2.1 version solving our problem. To become a beta tester:

To become a beta tester of the Nuki Android App go to the Nuki App in the Google Play Store and choose “Become a beta tester”.

Thanks for the hint :slight_smile:

I got one step further with my bridge recognized but no way to pair the bridge with the lock. They are both face to face 3m away but I get the error message saying they are not in Bluetooth reach.

… I keep going .

Geert, you are me!
Did you buy it from CB too?
Batteries dead on arrival. Could not believe it and took me over a day that batteries with expiration 2021 were simply not working.
Same bridge problems here with a samsung 7.
Ridiculous!
Ivo

Hi Ivo, I bought mine a Conrad.nl.

Very disappointing start… and we are about to trust our ‘safety’ to a device that is giving us a very hard time installing it.

If I cannot get my bridge connected I can not use the smart lock for my Airbnb guests and that was the main reason for me to buy it.

I have applied to become a beta tester and hope I will become one by tomorrow so I can get my bridge operational before my next guests arrive…

How did you manage to get one step further? I have been checking to see if mij Wifi router supports 4.2 Ghz (and of course it does). I also changed the channel on which my access point is broadcasting from 6 to auto, but unfortunately this did not solve the problem either.

I managed to get my bridge paired with my lock by using the pairing process without app : You press 5 sec both on Lock and Bridge to get the devices in pairing mode (light constantly glows). After some some, the bridge started to blick. I rebooted the bridge and when I got to the lock “connectivity screen” in the app, I saw the bridge was properly paired and I had connectivity to my lock through the wifi.

Hi!

Good to see you helpint out each other.
Things I can add maybe:

  • We had issues with batteries running empty on transport, but that should have been solved now. Seems you got one which was on stock for some time.
  • If you have issues setting it up after batteries have been totally emptied consider to do a factory reset to be sure everything is fine.
  • The Nuki Bridge will automatically go to maintainance mode (flashing continuously, yes - see https://nuki.io/en/support/bridge/bridge-features/bridge-signalization/) if it is not set up yet. So If you plug in a new one there is no need to press the button for 10+ seconds (as it i slater on). This might be missleading in situations where it doesn’t work in the expected flow.
  • There is an issue with some Android phones having problems to connect ot the Bridgein maintanance mode we are adressing with the current Android Beta App. Else you could also try to use another phone for setup (if possible)

In general you can call our support (or contact via contact@nuki.io) for direct help on our issues.
These only were some general hints that might help, but every case can be different and there may be the need to check IDs and log-files to debug, which should not be shared here.

Hi Stephan,

I have applied to become a beta tester, hoping that I could obtain the newest firmware and thus solve my problems. How long does it take to become a beta tester?

Do you mean for the Android App? This is an automated process in the Play Store which should work within minutes.

Updating my phone app to the beta version indeed solved the bridge problem I had. So now my phone can ‘see’ the bridge. But the paring of the brdige with the smart lock is still not working! I get the error message 506: … you have to be within Bleutooth range. My bridge and Lock are only 50 cm apart so that cannot be the issue.

Just go for the classic pairing as mentioned by Vincent above: Push buttons on both devices for 5s and they will find and pair themselves automatically.

I have only tried that about 50 times…with no success. I do not think trying again is going to solve this problem…

Hi Ivo,

I maid some progress but I still cannot activate the Nuki Web Account…

The solution to my problems was:
1: Get the Beta version of the Nuki App: Go to Play Store, lookup your installed Nuki App and look for something like ‘Become beta tester’ This will download the newest version of the App to you phone
2: Factory reset your Smart Lock, this is not the same as deleting it from the registerd locks in the Nuki App. You realy need to find the Reset Factory option.
3: Factory reset your bridge
4: Verify that your Nuki Smart lock app is the (beta) version: revisit the Play store and once again search for the nuki app. The title should now show Nuki Smart Lock (Beta)
5: Open the App
6: Setup the Smart Lock
7: Setup the Bridge and make the connection with the Smart Lock. This time it worked for me.
8: the final page shows a Server Icon connected to a Bridge icon connected to the smart lock icon.
9: the only option I now see is in the right upper corner. Pressing that check icon, I get the message ‘Rebooting bridge’ and all the above done action seem to get deleted again…

Thanks Geert for your folluwup, after over a week customer support indeed told me to try the beta version. I did download that and I could indeed give in my wifi password and the bridge is connected to wifi. However the connection between the bridge and lock still wont work. It gives fault code 506.
Answer of nuki support: it can last 24h for the connection to be made.
Ivo