Can not activate MQTT on Nuki 4


I have a Nuki 4 non Pro. It is already connected to Home Assistant with Thread/Matter.

I red on Nuki page that Nuki 4 supports MQTT over Thread. So i tried to activate MQTT in Nuki App.

But I get the Message that I should add the Nuki to my Network.

What does this mean? It is already connected to my Network.

Anyone know what the problem is?


Nobody has an Idea?

Attached are Screenshots

You need to disconnect the Nuki Bridge (button in your first screenshot) in order to enable IP connectivity via Thread/WiFi on your Smart Lock.

Please add (MQTT SUPPORT) for Nuki Bridge

This would be the correct place for your feature request to get visibility and collect votes for it:

I don’t have Nuki Bridge.

But i pressed the disconnect button.
Not it looks like this, but i can not activate MQTT anyway.

It’s the same. Can not press button activate mqtt.

Seems you did not enable NAT64 within the “Open Thread Border Router” Home Assistant addon settings.

Also see Smart Lock (4th Generation) - Set up Home Assistant for Remote Access via Thread