Auto Unlock Problem

Hey,

I just installed my Nuki Smartlock. The Auto Unlock doesn’t work for my IPhone 12 Pro with IOS15 Beta.
The geofence is set to 100, if I am 200m far away it’s out of Home. When I go back to home, Autolock is turned off. Does anyone know why?

I tried all this with an android Phone, works fine.
Is it maybe cause of IOS15 beta?

Greetings

Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

Hi, I have the same problem with several Android mobile. I have found if I leave the Geofence as fast as possible and far away (e.g., by car) then the auto-Unlock works. Only if I move in close range (up to 200m), the app believes that I am within the geofenace. This should have to do with an inaccuracy of the GPS signal. Support in Austria meant this problem already fixed. Unfortunately, I could not check this so far.

Same issue here. I went outside of the geofence and saw that the status was off and the AutoUnlock was on. Then when I entered the fence it was turned off again and of course nothing happened.

It would be really really good from the nuki team to tell us how exactly is this thing working. It is absolutely not possible to test it by normal means.

When being away for long time with the car and coming back - it is working just fine!

Same issue here since we upgraded to iOS15. Any idea what we can do to get the AutoUnlock function working again ?

Turn off Auto-Unlock & Smart Notifications , reboot the iPhone, turn on Auto-Unlock & Smart Notifications again.

Good morning Jürgen,
thank you very much for your hint. Unfortunately it did not work with none of our 3 iPhones (all since we have iOS 15 installed). Any other idea ?

Install iOS 15.0.1 and try the same. You might need to wait a few exits and enters for it to work. First AU can still fail.

If that does not help too, send error reports to customer care via the Nuki Apps “Contact customer care” function. This will generate a package with log files for the devs to look at.

Same Issue here since iOS15. Workaround didn‘t help. The Auto Unlock function works in 2 out of 10 times. In 4-5 cases I even do not receive the push. The other 3-4 cases I receive the Opener could not being started.

Same here. With IOS15 auto unlock is not reliable and useless. I got the usual standard response after contacting the customer care via the Nuki App. Please take this problem serious. For me, it is a show stopper.

Are you also talking of the Opener or the Smart Lock?

P.S. Auto-Unlock mostly relies on operating system functions. If they don’t work or become unreliable with an operating system update, it’s usually a problem that needs to be fixed by the operating system provider. It could therefore be useful to contact Apples customer care and see if they can find reasons why geofences don’t trigger or trigger too late in your usage scenario. They also have the advantage of having access to device logs to which Nuki does not have access. → https://getsupport.apple.com/

Or you develop an app according to their specifications. Why should apple care if your app is not working? Yes they have changed their software framework but it is you who will lose customers.

1 Like

To give a diplomatic answer to your accusations: We are well aware that customers blame the smaller one, who is closer to them (Nuki) rather than the larger one (Apple) when something does not work as expected after an update. Which is why we are looking into it and try to find solutions to improve the situation.

Nevertheless i would recommend to install the latest OS updates and test if that helps. iOS 15.0.2 is available since yesterday. Please give it a go and report back if AU does work better with it.

I’m not accusing anybody I’m just stating the fact that Apple will not care that a core functionality of Nuki is broken. Clear communication keeps customers happy. Thanks for your last statement.

1 Like

We have created a support article for this topic: After updating my iPhone to iOS 15, the Auto Unlock feature does not work properly. What can I do? – Nuki Support.
There we will also publish further findings and troubleshooting.

here too the same problems with IOS 15. Since the latest IOS, auto unlock works almost not at all. Deactivating the private relay function makes no difference. Is there already a solution?

Same here. Problem lies mostly with the Opener. Occasionally Auto-Unlock works. Most often not. Before IOS 15 it was 100% reliable, now it works 2-3 times out of 10.

1 Like

Please follow the advice in the article linked by @Elisabeth_B. If you end up with submitting a support ticket you can also DM her or me the ticket ID.

Yeah, followed the instructions from the article. Will try it out for a week and see if it alleviates the problem.

1 Like

Well I followed the instructions. But the problem appears again (worked 3 day’s). If do the instructions again it works again but it stops after some days again