Auto Unlock is not working on second phone

Hello all,

My wife and I both have an Android phone. I have the Galaxy Fold 3 and my wife has the S20 FE.
For me, the Auto Unlock works quite well when I approach the radius. I can also read this in the log.
With my wife it does not work at all. The log says that she is leaving and entering the geozone and a smart lock was found. But it doesnt open.
Battery optimization is off, GPS is on, all rights are assigned and also “not killing the App” is on. But the Nuki app doesn’t even sceint to register that the zone is being exited or entered.
What can I do?

At first, set the radius for auto unlock to 200m.

I have already tried that. It is also given as a tip here in the forum.
The radius seems not the problem. The phone responds to geofence and is also registered within the radius. I can see it in the log file.
It always appears the message in the log file “Smart Lock found” and then “Auto Unlock canceled”.

I dont know if its a bug, but since two days it works also not anymore for me, but now I have installed a new nuki app update, and have to look if this change!?

I have the latest Beta version on all phones. I was hopefull this will help… but it doesnt

I have installed it just now, look if there is a newer one!?

Last Update was yesterday or today morning. I am not sure

Have you paired the second phone over Bluetooth with the nuki lock.

No, I added the other phones through an invitation. What’s the difference?

Maybe it depends anyhow, because autounlock has two triggers, one from Geofence and second from Bluetooth (when your phone comes in range of Bluetooth of the lock)!? But a other thing, I looked in the expert settings of auto unlock, and it was set to do nothing on the options “Geofence entered” and “leaving Geofence”, - look what is set there, and pair it with Bluetooth, maybe it helps!?

I’ve exactly the same issue. In one of the phone works well, on the other not. I also enabled notifications, to see what is happening.
I even came home with the app opened at “Show map” to see the status:

  • when I entered the geofence in the map, I got the notification and the bluetooth icon started to blink
  • when I came close to the door, the bluetooth icon turned solid, but no notification was received. Also the door was not opened.
    Then I looked at the log, and it says auto lock cancelled. The phone was paired with the lock.
    See screenshot with the logs attached,.

@Rose_Languste @uncas

I have the same picture like you in my two phones. Only my main phone is open the doors. My main phone is the phone, with the first pairing of the Nukis.
I have also paired the other two phones new, but I got “auto unlock cancelled” everytime.

I can’t understand why auto unlock is only working for one phone and “auto unlock cancelled” on the other two.
So auto unlock doesnt make sense for my wife and Kids.

It makes a lot of sense to filter Auto-Unlocks when several people (Smartphones) come home at the same time. You can read more about this here: https://support.nuki.io/hc/en-us/articles/360015983938-Auto-Unlock-Nuki-unlocks-your-door-automatically

Hello @Juergen

that has nothing to do with it at all. There is no one at home all day. Doors are locked. My wife comes home. Geofence reports and says “zone entered”. She then stands in front of the doors and not one of three opens and the log says “auto unlock cancelled”. Why does it say that? Why is auto unlock cancelled?
The same with my son’s phone. Exactly the same.

But when I come home with my phone, all the doors open by themselves.

There must be someone who can explain why that is.

Customer Care should be able to help. Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

@Juergen

I already did that on 10.11. Here is the ticket number (see below). Still nothing heard until today. One feels then already left alone…

Lieber Nuki Kunde,

wir haben deine Nachricht erhalten und melden uns in Kürze bei dir.

Dies ist eine automatische Bestätigung deiner Supportanfrage.

Ticket: (130551)