Auto unlock funktioniert so gut wie gar nicht

Hallo,

wir haben ein Problem mit dem Unlock. Wir nutzen nuki seit ca. vier Monaten und bei meiner Frau (Samsung), als auch bei meinem Sohn (Honor), als auch bei mir (realme) klappt es von 50 mal vielleicht einmal, dass nuki die Türe öffnet und mir das auch dann auf dem Handy mitteilt. Die allgemeinen Hinweise (WLAN an, Handydisplay an, etc.) habe ich alle schon angewendet, aber leider ohne Erfolg. Batterien sind auch neu. Dennoch reagiert nuki nicht. Es wird zwar protokolliert, wann ich Geofencing verlassen und betreten habe, aber die Türe ist fast immer zu und ich muss sie manuell öffnen. Genau wie meine Frau und mein Sohn.

Was kann ich machen, dass es besser wird, denn so macht es keinen Spaß.

Ich danke für Hinweise und Tipps.

noch schlimmer als das nicht funktionieren ist folgendes:

Das Nuki ist an der Haustür im Wohnhaus.

Mein Büro ist 3 Häuser weiter.

Komme ich nun ins Büro und fahre nicht nach Hause), öffnet Nuki die Haustür obwohl ich nicht in Bluetooth Nähe bin, sondern ca. 100 Meter entfernt.

Daher habe ich Auto Unlock erstmal deaktiviert.

Das ist nicht möglich. Autounlock sperrt nur via BLE (sofern man es nicht über Expertensettings „verkonfiguriert“ hat).

Btw. this is an english speaking developer forum. Therefore please continue the conversation in English if it is a developer relevant topic.

1 Like

Hello,

We have a problem with unlocking. We use nuki since about four months and with my wife (Samsung), as well as with my son (honor), as well as with me (Realme) it works out of 50 times maybe once that nuki the door state and tell me that also then on the cell phone. The general effects (WLAN on, cell phone display on, etc.) I have all already lost, but unfortunately without success. Loads are also new. Interesting nuki not. It does log when I left and heard geofencing, but the door is quickly always closed and I have to open it manually. Just like my wife and son.

What can I do to make it better because it’s not fun like this.

I thank you for instructions and tips.

Andreas, please contact customer support through the Nuki App > Help > Contact customer support feature. This will create an extensive report and give them/us all informations needed to debug your problem. Usually Auto Unlock problems are followed up 1:1 with support as they are often individual and require sharing of sensitive data (e.g. your location).

Hello,
Please post any possible solutions here, as I have exactly the same problem (AutoUnlock works in ca. 1 out of 50 cases). It is a nice feature - if it works).

I did already experiment with different RSSI Threshold values in the expert settings, however without success.

Best Regards,
Sebastian

I also have to connect here … Samsung Note 20 Ultra opens the apartment door from what feels like 100 x maybe 5 x … we have tried all the possible settings … that cannot be in the spirit of the inventor …
Best Regards,
Matthes

Support got back to me after four days and gave me tips and advice. I will now implement these and see if it gets better. If these do not work either, I should send a bug report.

@Andreas Buchheim - did have successfully implemented the tips & advice and does it work as designed ?
My wife & and me have identical smartphones (LG 7fit) Android 9- Nuki app up to date - firmware up to date. Geofence set to 200 m (!) Auto Unlock does work once out of approx. 10 times. We use Nuki2.0 since 2 years. It worked succesfully for many month. Nowadays not anymore. We can tell that entering the geofence by car it triggers message "your are near bla bla bla … shall I opene the door ? Press button YES - Auto Unlock works when we are near the door. But when entering the geofence walking we get no message and when close to the locked door nothing happens. Our verdict: useless bit of smart home gadget.

Hi Axel, please send us the the app logs (Help → Contact customer support). Please take a note when you entered via car and when by walking. Thank you!

Stefan, I’m unable to pull the logfile - Button Help - Contact customer suport - shows me (after entering my email address) Screen Where do you need help ? I do search for logdata or ligfile = no results.
Many month ago I could pull the logfile (xxxxx.gz) - pls give more detailed advice.
thanks
edited: I do want to send the logfile to my email address to find the times when entering geofence by car and by walking

Make sure you upgraded to the latest version of the app (2.7.6). Enter your personal data, select your Smart Lock, choose “Troubleshooting” as category and in the next step enter the time/date when you experienced your problem(s) (that makes finding the relevant data a lot easier to find). Submit the request.

Stefan … I’m on release level 2.7.6 but I don’t get the choice to select anything (I do have only one device Nuki Smart Lock 2.0) . What do I do now ? Factory reset ?

update/edit: I didn’t know that the files app.data.gz and devices.log have been send automatically to the support team. I have got a reply from the support team (Mrs. Soufiane) - thanks.
But I’m not able to figure out when I came back entering the geofence walking and auto unlock didn’t open the door. The only time (approx.) I know when entering geofence with car is 2021-03-25 15:07,397
rgds Axel

Hello Axel, unfortunately nothing has changed. The Nuki support gave me general hints, which I followed all. The frequency of the door opening automatically has not increased.

I was told if this does not help to send a bug report to support via the app. So exactly what you did as well. I will now do the same. I copy once the complete answer of the support in here:

Hi Andreas,

Thanks for your message.

Auto Unlock is influenced by various factors and sometimes requires a “learning phase”. This means that the operating system of your smartphone and the Nuki app have to get used to each other first. We therefore recommend to activate the Auto Unlock feature and test it over a period of several days. Please do not deactivate the function if there are any problems - otherwise you will interrupt the learning process of smartphone and Nuki app.

Under the following link we have also summarized some tips to improve the Auto Unlock quality:

It is crucial that the Nuki app is not limited in its function by any energy saving modes.
Depending on the operating system of the smartphone or even the version of the operating system, system updates may automatically activate energy saving modes. Even if you had already disabled them for the Nuki app, the settings might have been reset unnoticed.
You can easily check this in the system settings of your smartphone and change it again if necessary.

We also recommend to set the geofence range as wide as possible. Make sure that the radius is at least 200m.
Auto Unlock is triggered by two “events”:

● Entering the geofence area
The establishment of a Bluetooth connection between the smartphone and the smart lock.

The Auto Unlock process is basically what happens:
As soon as your smartphone crosses the geofence boundary, the operating system detects the position and “wakes up” the Nuki app. It then starts the Bluetooth scan to find the Smart Lock. As soon as a Bluetooth connection can be established, the lock is activated via Auto Unlock.
If the geofence area is configured large enough, there will be more time for this process.

After you have adjusted all settings according to our recommendations, please reset the Auto Unlock function. Simply deactivate all smart actions, restart your smartphone and then reactivate the desired functions.

Test Auto Unlock with the changed settings for a few days and give the devices some time to go through the “learning phase” again.
If the problem persists contrary to expectations, please send us a bug report via the internal contact function from the Nuki app.

To do so, please go to the app’s main menu under Help and select Contact Support.
Please select the name of the affected device and make sure that you are within Bluetooth range of this device when sending the request.
As a description of the error, please simply enter your current ticket number #######.

Please also provide us with the specific times when Auto Unlock was not performed at all or not performed in a timely manner. Additionally, a screenshot of the corresponding action from your log and a screenshot of the last Auto Unlock can be helpful in the analysis. You can get this view under the menu item Smart Actions in the Auto Unlock settings. Select the menu item Last Auto Unlock and save the displayed screen.

If you still experience problems, please send us the relevant information as described above so that we can analyze the situation in detail.

Best regards,

@Andreas Buchheim - the support team send me a reply (same day) including the name of the logfile.
I did’t even know that the logfile “app.log.gz” was sent in the background when I was at “troubleshooting smart lock” “improving Auto Unlock” in the Help Menu. In previous times I could pull the logfile and could unzipp it to figure out what happened when - that’s not possible today. After 8 days I got the following results:

** Apr 7, 2021, 9:43 GMT+2**
Hello Axel,
thank you very much for the error logs.
Our product manager Stefan checkt the logs and he has the following information for you:
2021-03-25:
===========
What is noticeable here is a hole of about 30s - that is an indication that Android has put the app to sleep. Remedy or tried: Press the power button on the smartphone (eg when getting out of the car) so that it wakes up.
2021-03-2515:07:08,977 - [FINE] SocketConnection .ym1$a:9 - socket connected
2021-03-2515:07:38,333 - [INFO] ScanDispatchHandler .cp1$a:40 - [scanner] scan result hp1{nukiId=369281557, macAddress=‘54:D2:72:02:CA:15’, rssi=-70, name=‘Nuki_1602CA15’, txPower=-1} matches the request BeaconScanRequest{}

SL then found after about 3s (OK)
2021-03-2515:07:41,457 - [INFO] BleConnection .tr0:59 - [54:D2:72:02:CA:15] ble connected after 2387ms on 1. try

Here the Auto Unlock would be already performed by someone else (successfully) and therefore rejected (OK)
2021-03-2515:07:41,927 - [SEVERE] BleHandler .um1$b:3 - [54:D2:72:02:CA:15] received ble error: dg0{channel=2, errorCode=KEYTURNER_ERROR_AUTO_UNLOCK_TOO_RECENT, errorType=0xD, message=‘null’}

If another Auto Unlock is performed within about 2 minutes, then it will be rejected.

2021-03-26:
===========
Some “holes” in the log, i.e. app didn’t catch all geo-fence events, or Android didn’t forward them. At 16:48 Auto Unlock should happen, there are no geo-fence events which are relevant. Further big “hole” in front of it:

2021-03-2611:12:54,692 - [FINE] FenceEventHandler .p62$a:16 - [fencing] task queue is empty - idling
2021-03-2616:17:53,991 - [FINE] ConnectivityThread .fencing_v2.FenceServiceV2$a:3 - [fencing] connection state change to disconnected - starting further validation

and

2021-03-2616:19:03,499 - [FINE] FenceEventHandler .p62$a:16 - [fencing] task queue is empty - idling
2021-03-2616:47:42,246 - [FINE] main .ui.activity.MainActivity:3 - [ui] onResume

From the app’s point of view everything Ok. Please consider these tips: Auto Unlock optimieren – Nuki Support. The status of the smartphone while walking is unclear.

Thank you very much for your help.

@tlchzj79 : in battery settings of your Android phone, did you disable battery optimization for the Nuki App? I have done that in a “One” Phone (Android 9 I guess) we use and AU works. I have no time to re-enable and try if it doesn’t work…

@uwe w - yes I did ! Checked it twice - no change

@tlchzj79 …no further idea currently…but I wonder what is different between coming with the car and by walking. Is the phone in the car always-on, like for navigation, or connected to a (wireless) charger?

@uwe - I tought that the speed is a reason when enteringg the geofence by car or when walking - but obviously not. Smartphone was not connected to charge socket & and no navigation app active - just inside my jacket, ready for communication with Nuki app. Sometimes I got the message (… should I open the door) - often not.
I usually don’t answer the message and wait until I’m near the door. At one occasion I did answer the message with “NO” and drove along and got another - again answerd with “NO”.
I did a hard factory reset (i.e. took out battery pack / pushed it in again whilst pressing & holding the central knob. I expected that I could start the installation process from scratch.
Deleted the Smart lock - deleted my own user - uninstalled the Nuki 2.0 app. Installed the app again and was surprised that all settings were obviously still inside Nuki’s memory and displayed in the app (e.g. activizy log / my user / my wifes user and all previous settings.
Conclusion: the factory reset is not what I expected that it should do.

update to my previous post:
After “factory reset via Nuki app” with option “erase all data” and new setup the SL for two users Auto Lock function works again.