APP UPDATE: Nuki Android App 2.6.4-Beta

We released the new Android app version 2.6.4-Beta .

What’s new?

• Display battery status in battery settings screen (critical or sufficiently charged)
• Auto Unlock improvements
• Performance improvements and bug fixes

Please update your Nuki app and give us your feedback!

Hello, I have an timeshift between smartlock found and auto unlock of 12-18seconds.
This leads through the issue that I need to wait at least 5-10sec in front of the door to wait until it gets unlocked.
This is much to long as within this time I’m able to open as well with a normal key.

Tested 2.6.4 & Autounlock is much better than before on Android 10.
It worked 4 days in a row, which was not the case before.

The mentioned delay from @Jochen_Mueller i havent noticed yet.

But there are 2 minor issues:

  1. One of the two devices triggers the geofence faster than the other!? Example: i get a notification for the smart lock before driving into my garage and 30s - 1min later the notification for the opener follows.
    Should’nt they appear/trigger exactly at the same time? They booth have the same range and geofence settings. Maybe this is the similar issue like @Jochen_Mueller described, just with two devices?

  2. The RingToOpen Notification will not be deleted from phone
    After i have used RingToOpen to open the door, the notification dont disappears on the phone. But when i look into the app and click on the opener -> no RingToOpen is active -> correct i have triggered it.

Here are the screenshots from issue 2.

I have made an debug log from the past days and will send this via PM to you.
Please can you take a look at those, maybe you find the issues.


I monitored following effect.

Ring2open is activated due geofence. And worked normal. But when I start the app 6 hours later and go into the opener config. First it tells me ring2open is active and time is decrease. After about ten Seconds later ring2open disappear and the normal open shows.

@MatthiasK: I have sent you again a log where AU failed.

Best regards

Hatte heute folgenden Fall der m.E. eine Fehlfunktion ist und so nicht passieren dürfte.

  • Stehe vor der Tür-kein Auto Unlock
  • Drücke die Klingel
  • Ring to open funktioniert und öffnet die Tür über Buzzer
  • Ich gehe rein, schliesse die Tür
  • gehe ein Stockwerk nach oben
  • jetzt erfolgt der Auto Unlock vom Smartlock
  • Tür wird geöffnet

I had the same behavior one time.
I think the smartphone won’t connect to bt during enter. But sometime later during timeframe of auto unlock the bt connection was successful so the door opens.

Korrekt der Opener wurde drei Sekunden vor dem Smartlock gefunden.
Der Opener hat dann mit Ring to Open/durch Klingel drücken geöffnet.
Erst 2:10 Minuten danach hat das Smartlock geöffnet.

Mein Eindruck ist das es nicht an der App sondern an der neuen Firmware des Smartlock liegt. Seit dem letzten Update vom Smartlock geht AU gefühlt wesentlich schlechter

Which Firmware Version are you currently running on the Smart Lock?

I have 2.6.6 on the Smartlock and 2.6.4 for the App.

@Jochen_Mueller Thx. We are investigating reports with AU issues for Smart Lock and Opener at the same time, so please - if possible - send a log-file with a short description of the problem and the exact time when it occured to our support team at, so they can check the details of what happend.


Ok already done a few days ago and yesterday due to another issue with AU caused by the opener/app.

I wasn’t sure how to handle complaints and Beta Feedback, therefore I particullary have had posted here and send in paralell to contact@nuki