Wrong Nuki smart actions are active - notification

Hi, all of a sudden on one of our smartphones (pocophone f1) the nuki app (3.0.4) showed a ‘nuki smart actions are active’ notification warning requesting location permissions, even though smart actions are definitely deactivated in the app options (those under smart actions (auto unlock) ). This notification doesn’t even go away when the ‘body activity’ permission (loosely translated from german) that it then seems to ask for when tapping the notification is granted. Location (the android quick setting) was already active even before and location permissions were also granted to the nuki app.
This seems like a bug/misbehaviour. Or is there another hidden setting that is linked to smart actions (which are not needed for us) that I can deactivate to fix this?

Edit: after giving Nuki a GPS location via the map selector dialog, which shouldn’t be necessary when smart actions are not active, the notification was reduced to ‘smart actions are active’ which is still a lie.

Do you have multiple devices configured in your app?

We have a door sensor and a fob registered with the (only) lock we own, nothing more. But at some unknown point later the notification seems to have vanished by itself, so for now it’s not a problem anymore.

Thank you, I’ve forwarded this for further investigation.