WI-Fi Issue SmartLock 3.0 pro

@Juergen @Stefan_Reiterer @MatthiasK
Hello, I have a Smartlock 3.0 pro and every time I restart it or I unplug and reattach the battery, I have big problems restarting the wi-fi.
But yesterday I installed the beta 3.2.1 I and was no longer able to connect to the wi-fi.
The network is correct and is stored on the smartlock but, even doing a further network detection it does not connect and gives a connection error …
Is it possible to reset the wi-fi without completely resetting the smartlock? Thank you

Same issue here after replacing the battery of my SmartLock 3.0 pro.
Wifi is configured, but the lock does not connect.
I’m running the latest official firmware and I could fix it by only reconfiguring the Wifi in the app.

@Juergen @Stefan_Reiterer @MatthiasK

I think there is a bug in the new firmware. I was able to set up Wi-Fi instantly (while with various Apple peripherals I had been trying for two days ) from an Android phone. When I try to configure it from an Apple phone or an Ipad in the past I have had big problems but this time it just couldn’t. I hope it can serve you as news.


hello if you can try with an android device let me know if the same thing happens to you

sorry, no android phone around here…

I think there are two issues: One is that the lock does not reconnect to the Wifi after replacing the battery pack and on top the beta firmware seems to have an issue getting configured using an iPhone

Update: the connection configured via Android unfortunately stopped working after 3 hours. At the moment, to avoid problems, I connected the smart lock to the Nuki bridge that I use for the opener

This may be a silly question. Is there beta firmware for the 3.0 pro lock? Or is it beta for the phone software?

Smartlock 3.0 pro beta.
With new beta 3.2.3 the problem seems solved

Just a quick update to the problems mentioned in this thread:

WIFI connect problems: We are still looking into this problem, which does not seem to be a firmware problem but more an iOS App problem. A work around is to switch the iPhone in flight mode (with bluetooth enabled) before configuring the WIFI network of the Smart Lock 3.0 Pro. Another one is to disable WIFI completely before trying to connect again.

WIFI stability issues:
The problems mentioned in this thread are fixed with Beta 3.2.3, which is much more stable in difficult environments (and consumes less energy).

Thank you for the feedback that you provided so far.

1 Like

Ok thx i will try this.

Hi NUKI Support, I am right now using the 3.0 pro hardware with the 3.4.9 fw version, and I’m also experiencing extremely annoying wifi instability issues.

It does nothing to do with my wifi setup, as there are both a powerful a/b/g/b/ac/ax netgear router at 5 mts., in line of sight, plus a repeater right next to the device (and every single other IoT device works perfectly well).

The previous iteration of the smartlock I used (not sure if it was v1 or v2, but it used the Bridge), never had this kind of stability problems.

I had of course tried many different possible solutions, like hard-resetting everything, without luck

(Note: my primary use case, which is the one giving the biggest problems, is:
Smartlock 3.0 Pro >> Home WIFI >> Internet >> Nuki Web API >> My own app running commands (e.g. open door).
Before, this approach had a response time of 1 or 2 seconds at most, now it doesn’t even respond, or if it does, it’s 5min+ later.)

Any ideas?

This is a duplicate. You’d better join an existing thread about connection issues.