Unexplained 422 Unprocessable Entity creating a notification


we are a small company with an existing solution to unlocking office doors and would like to interface with a smartlock 3 pro.

To that end, we need both a way to trigger unlocking, which the web API handles fine, and a notification whenever an employee uses the app to open a lock.

I tried creating a webhook notification through the API and all I get is a generic 422 Unprocessable entity, which is deeply annoying, tbh.

I used the provided JSON example and adapted it to our needs according to the model annotations. But even the most bare-bones payload will return the same error. The 99999999999 gets replaced by the real lock ID, retrieved by GET /smartlock

  "notificationId": "testhook0",
  "pushId": "https://our.custom.domain:7777/lockaction",
  "os": 2,
    "settings": [
      "smartlockId": 99999999999,
      "triggerEvents": [

I saw the announcement of the advanced API for decentralised webhooks but since it is heavily branded towards system integrators/resellers, I did not think it would apply to us.

Grateful for any pointers, kind regards

Hi Moe,

We checked the API documentation for PUT /notification and realised that there is an error. Do not provide the “notificationId": “string” in the endpoint as the PUT response will return the notificationId.

“pushId”: “https://our.custom.domain:7777/lockaction”,
“os”: 2,
“settings”: [
“smartlockId”: 99999999999,
“triggerEvents”: [

Thanks for highlighting this, we will fix this shortly in our API documentation (Swagger UI).