Token issue using Homey

Hello,
I’a Homey user
I can’t use my Nuki V2 with Homey ( ios, but same problem with windows)
At first The lock was working but logging out every day and I was using “fix” over and over.

So I did a “hardware” reset and uninstalled the Nuki app, as well as the Homey app, I deleted the Nuki Web account.

After reinstalling everything and creating a new Nuki web account, I can no longer use my lock with Homey I have the message “could not parse token response’

Any idea to solve this problem please?

Thank you.
Yann

3 Likes

I have the same problem. So I hope a fix is on his way.

1 Like

Yes! I’m so glad I at least could find some reference to this issue. But it’s exactly the same for me. I was already annoyed at the fact that I needed to buy a Nuki bridge as I don’t understand why it can’t just pair with Homey via bluetooth. So having spent another 100 Euros just to get it to pair with Homey AND have it only work for a couple of hours, that REALLY salts my apples.

I talked to the retailer and all they could find about it was that it could be a firmware issue, but they couldn’t tell me where in the app I would even be able to find what the firmware version of the Bridge was. I can find it for my Opener, but not the Bridge. They suggested I sent it back so they could have a look at it, but as other people seem to be having the same problem, I’m not sure they would be able to solve it. Yesterday I emailed both Nuki and Athom customer support, but I haven’t heard from them yet. I will of course share info if I find out more.

1 Like

Hey, I also had contact with Nuki support, but after a few tryes, the guy gave up, at told me that his manager will contact me within a few days… still waiting…
So I have installed Nuki Direct App, it works perfectly and is a local solution :smiley:
So Adios Nuki app!

Oh wow, I did not realize there was also a community app for Nuki. I’m gonna give that a try ASAP. If that works (and keeps working); I owe you :slight_smile: And the maker(s) of that app as well, of course.

Cheers!

So, I’m not sure if I even know what I am doing here. I installed the Nuki Direct App, but it says that no Bridge has been connected to the Nuki servers in the last 30 days with that same IP. That’s simply not true, I can see both in Nuki Web and my own router that the Bridge IS connected to my WiFi network.

There is an option for manual pairing and I tried to (fill out the IP, but I’m not sure of the port and where to find that) and either I’m doing it wrong, or it just doesn’t work. Is there anyone who can guide a newbie through this?

Hi.
Im was struggling same things. Now, it worked with Nuki Direct App for the Nuki 2.0s, but not yet for the 3.0s.
I did the manual pairing. You get all the infos when you jump into the administration of your bridge then tap on the bridge icon. There you see the IP of your bridge, Standard Port is 8080, and you get the token

Ah, I generated a token through Nuki Web. Or what I thought to be a token; my version isn’t in English.

But now I’m in luck apparently, as I have the 2.11.0 version.

I can see a Bridge ID, which corresponds to the ID that shows when I log in on my router. Do I need that in some way? I do not see an IP there, but I already can see that on the router. I guessed the Standard Port, but I don’t get a token except for what I generated through Nuki Web. And that didn’t work.

Edit: scratch that, I found it. Now see if this works…

Edit.2: Ah shoot, I still get the old “could not find that PairSession” :unamused:

Hi,

Bought a new Nuki 3.0 Pro, works like charm, but I can’t connect to my Homey, problem with the token, “could not parse token response”.

Thanks you all, Nuki is aware now, and hopefully solve the problem soon.

Kind regards,

Ed Rabenberg

I have the same problem. Repair does not work. I have reported this issue with Homey Support, because Homey is the owner of the app and responsible for the communication (token) between the Nuki web and Homey. Nuki developer was working on it and would contact me when solved or when there is a solution. Hopefully soon. I have trust in the Homey developers and Homey Customer Support. This issue is recent and should be fixable by Homey experts.

I have very little knowledge about this stuff, but Homey support told me that their developers have concluded that it is caused by the API from Nuki. So they cannot do anything about it since the API is maintained by Nuki itself. They have reached out to Nuki, and adviced me to do the same.

I also got a reply from Nuki; they told me to delete the integration and then reintegrate them. I suspect the person who replied to my email didn’t know about this particular issue. But needless to say, their suggestion didn’t work. I’ve sent them an email explaining everything I tried with the specific error messages, maybe that’ll help in some way.

But you say this is a recent issue, so used to work before this? That gives me some hope. I just bought it, so for me it never functioned as intended. Or wel… it did, for three or four hours. So I tested it and it worked fine, and then when the first person rang the doorbell and I wanted to actually use it, it all just fell apart.

Indeed, this is a recent (2-3 weeks) issue, and my Nuki doorlock + opener were working fine for over 2,5 years now. So it will work
again, after the Homey experts have fixed the problem. I doubt that Nuki can/will fix the problem. The Nuki app in Homey is build and maintained by Athom = Homey, so they have to fix the issue and they will.
Have faith and some patience.

Just to confirm you here that we are in contact with Homey and looking at the issue on our side. Will keep you updated as soon as we think it makes sense to retry.

I just got informed that an update from yesterday should have solved the issue with Homey. Could you please recheck/confirm if the error still occurs for you or not?

Hi Stephan,

I tried it extensively yesterday, and again just now. It seems to behave a little bit different, but now I cannot add Nuki devices at all. The app behaves like it does when it adds a device, I can log in with my Nuki account etc., but when it asks you to ‘select device’ I cannot select any device. The app still says it’s adding a device and acts like it would if a device was actually added, but it’s not adding anything.

I tried this for a long time yesterday, unlinked the associations with Homey and Google Home from Nuki Web, did a factory reset of the Opener, deinstalled and reinstalled the app on my Homey, etc., and tried it again after every step. But I got the same results I get just now: it says it’s adding a device, but it just… doesn’t.

Dis you installed the test version? : Nuki | Homey

Hey Stephan, I have installed the homey app test version and the problem seems to be solved.
Thank you👍

1 Like

Hi @SortOfSmart Could you PM me the Nuki Web account you used for connecting so we can check our logs for it?

@Stephan : Will do!

No, I did not even know of it’s existence. Should I?

Edit: ah, I got an email from Homey saying they made the test version to solve this issue. I’ll try that then. Will let you know how it goes.

Edit2: Nope, same result. I get the “select which device you want to add” without actually having any devices shown. Then when I press “next”, it says “adding devices…” like it is adding a device, but it isn’t actually adding anything :frowning_face:

Edit3 (hours later): for some reason, I thought to try it again in the browser version on my laptop instead of on my phone. And what do you know… now there IS an opener to add. I have no idea how or why, not in the least because the very first time, I DID pair Niki and Homey on my phone and then it worked (at first…).

So, it works. Why I couldn’t add it on my phone even after thirty or so tries… I have no idea. Sometimes apps don’t work properly on my phone because my phone is significantly smaller than most (I like my phone to actually fit into my pocket) and some apps aren’t made for that. The Google Home app is a prime example, I can’t read the text for voice match because part of the text just isn’t visible on my screen. But since it worked fine at first, I find it a little odd that that would’ve been the problem.

But to summarize: it works for me. For now, because I still don’t trust it entirely. When I first paired them it worked as well, and then it stopped working after about four hours. So I’ll report back in a while :slight_smile: