Smartlock often offline when trying to open it

I am finding that I often get home, and when I open the app it says my smart lock is offline. I have to then wait about 30 seconds and it will show online and I can open it with the app - does anyone else have this issue or know what might cause it?


iOS or Android?

How long do you have your nuki? Because at the beginning I had this to, but its going away after a little while!? Except you try to open with a Smartwatch, this is to now not really working!?

It happen son both iOS and Android. It happened a lot, then it stopped but now it has come back again.

This runs mostly over Bluetooth, is your lock in good sight of the bridge!?

Yes - they are probably a metre or so way from each other so I don’t think this should be an issue.

I experience same problems like Harry. Sometimes app shows ‘offline’ then I try a minute later than it is online and can open.
In other thread (Smart Lock offline - #38 by Pawel), I read that it could have something with adblocker or custom DNS on phone… but right now I can’t check it, cos I am away.

Distance between Nuki, Bridge and Router is minimal, everything in same room (hall).

Accu optimization is turned off for the app in android, and the foreground service is activated in the nuki app?

I have adblocker and DNS, and no issues, but of course I take the nuki app on the whitelist of these services for no interference, and have you disabled all accu optimization for the nuki app in Android, and enabled the foreground service in the nuki app!?

I’ll double check all these but I think they are all correct. Also, this happens on my wife’s phone (iOS) as well as my phone (Android) so I don’t think it is a phone issue…?

I noticed this: after leaving door locked for almost 2 months and haven’t connected to it by apk either:
app on android showed that it is offline for more then 30 minutes, I tried to connect by app 6-7 times, and then maybe after 8th finally succeded and connected and showed ‘locked’.
Now, when you try to check connection it connects immediately… so maybe some longer time without apk ‘use’ has something with it, maybe Nuki servers push less active devices ‘down in order’?
I have Nuki 2.0 & Bridge, app is on Android, and everything is enabled, no battery savings enabled.

And finally I disovered main problem in my case: some kind of incompatibility beteeen that router and Nuki Bridge. With old router sometimes I was getting offline message, but since change, with new router (simple, very cheap one, i wanted to check it only, Xiaomi 4c) it is always online. Already whole week and without any message ‘offline’.
Why old one makes some problems while connecting to Bridge is still enigma.

1 Like

Hi, I experience the exact same issue. I often have to wait 20-40 Seconds until the Smart Lock (3.0) gets online on the App. I don’t have a bridge and I tried many things to solve this bug NOTHING worked. The bug also happens when I only use my bluetooth and have wifi and data off. So this is definitely a issue off the Lock. I tried it with different phones, power off-on. No app optimization nothing. Nothing worked. Does somebody know how to finally resolve this issue?