Smart lock- Set up problem

I just bought a Nuki Smart lock 2.0, Nuki bridge and Nuki keypad.

I use an iPhone 12 running iOS 14.6

I have installed the Smart lock onto my door and downloaded the Nuki iOS app. Bluetooth is on but the app does not find the lock.

I have tried restarting the phone, turning Bluetooth off and on, and taking the batteries out of the smart lock then putting them back in.

Does anyone know why I cannot get the lock working?

Screenshot attached.

Had the same problem. Support promised to release a fix in the next couple of days. If you don’t want to wait proceed with the following steps:

  1. install TestFlight version
  2. go back to Version 2.7.9
  3. setup lock as normal
  4. update firmware
  5. update to lastest TestFlight version or end testing and use stock version
  • Berni

Hi Berni

Thanks for the suggested work around. I have installed test flight, but how do I go back to the previous version 2.7.9?


Tap on the App and select the last entry in the App informations section named “Previous builds”.

In case you haven’t registered the Nuki App check this post: iOS Beta

1 Like

Thanks :slightly_smiling_face:

Hi! I have the same problem, but I am already using one Smart Lock in a different house and would like to add a new one in a new house. Unfortunately, I can’t pair the Smart Lock and don’t want to harm the Smart Lock settings already in use.
I have no idea how to install the TestFlight version … and so on.
I am using iPhone 12Pro, and I tried all the logical steps like reboot, reinstall, …
Any help?

Please give it a try with version 2.8.0 available at TestFlight. This release contains a fix for this issue. If it still persists please reach out again. Thank you.