Smart Lock / Position detection - Potential bug

Is anyone of the developers actually working on that?? Support just asked me to stay patient until a next firmware update… no ETA -.-

1 Like

Our team is currently working on a fix for this issue, we are very sorry for any inconvenience caused by this unpleasant behavior.

In the meantime I’m kindly asking you to give me quick vote on which firmware version you are currently running on your Smart Lock.

  • older than 3.2.8
  • 3.2.8 Release
  • 3.3.x Beta
  • 3.3.5 Release
  • 3.4.x Beta

0 voters

Please let me additionally know if you want to join the beta group as there will be a more stable version available soon. To do so simply send me your Nuki ID via private message.

Thanks for your patience.

1 Like

Unfortunately, the beta doesn’t fix it. In contrast, position detection increased up to all 3 minutes

Is there a possibility to downgrade?

No, once you are on beta you cannot go back to official firmware.

That cannot be true (hopefully).
Usually, downgrading is a common option.

1 Like

Same issue for me

@Stefan_Reiterer When can we expect a fix to this problem? I have guests in my rental house that are starting to get annoyed from the lock making noise once every hour. It is affecting my business.

Same here, but with the problem that my door opens completely. I have the problem 2 times a day. It gets really bad when it’s 3 o’clock at night.

Hope there will be a solution soon. My guests rightly complain that the smart lock starts reposition every hour throughout the night.

SmartLock 3.0 pro
Firmware 3.3.5

I have the same issue in France. Firmwware 3.3.5 official.
Nuki smart lock 3 pro just installed 2 adays ago.
It is impossible that I keep this door lock with an issue like this.
Please give a solution very quickly.

Do not update to the beta, it does not fix this problem (for me).
In contrast, it gets more worse than before (almost all 3 minutes position detection) and as I noticed, downgrading is impossible

Received from NUKI SUPPORT, problem is concerning SSL certificates:

This position detection does not affect the functionality of the Smart Lock and after completion the device is available again without any restrictions. Please know: There can be no unwanted opening of your door - so there is no security risk whatsoever!

In the meantime, you can temporarily deactivate your built-in WiFi to avoid these unwanted position detections. You can do this in the Nuki app under Settings - Features & Configuration - built-in WiFi . Please note that the remote access to your device is not available when the built-in WiFi is disabled.

Of couse this solution can be used from private customer…
I hope bug will be solved asap.

Same here. Started 2 days ago and woke me up last night. I’ll disable the wifi in the meanwhile. Thank you!

Same issue with a brand new Nuki, it came with firmware 3.3.5 (or was updated automatically in the first setup) could never make it work with WIFI…
The lock is open and close itself once in a few minutes. i cant understand how come you are saying there is no risk in opening the door…

Something must be made and fast :((((
Yesterday my pro 3.0 just went nuts.
It detected position each 3 minutes for a whole day, draining almost completely the battery!!!
I was out of town and came back to 12:30 AM this morning… I believe whole building knew something happens in my apartment.
Had to remove the battery completely :((

Today, surprisingly, no issues up to this time

Attached a small capture from a very long log…

Indeed no issues, but no my Nuki is offline all the time.
No way to open the door without a key.
Starting to doubt about the product.

Same here, in the middle of the night. Hope fix will come soon!

@Stefan_Reiterer any update on the position detection issue? Seems it’s linked to the recent Nuki server update.

My 30 days of return guarantee are coming to an end…

Last week we did another update of the Nuki server which solves the issue of the rebooting and repositioning Smart Lock 3.0 Pro.

If your device is still behaving strange I’m kindly asking you to exchange/charge the batteries and perform a manual reboot by removing the batteries. Please DM me if the behavior still persists.

In parallel we are currently also working on a firmware fix for the stated issue to improve the overall system stability, you will be informed as soon as an update is available via following channel:

1 Like