Smart Lock offline


I tried removing Alexa and iftt integrations
Result Is the same.
Shortly connected then offline

Status screen above in android Is All connected.

Tried to repair Android bridge to nuki.
No change :frowning:

Changedd mobile bridge.
Same result.
After the First interaction the lock goes offline for and for remote access

This needs to be fixed asap

How manu users are experiencing It? Is It only on Android bridge?

Really a breking bug

Nuki just went today again “offline”. This is becoming a real pain and gives no trust in the Nuki.
When is the update ready? Thanks for an answer

Stephan, i wrote to the support, but never got a feedback/reply.

I don’t know of other Android Bridge users with the same problem and can’t reproduce it here with me. Did you already send a debug report from the Android Bridge App to support? Else you can also send it to me via PMfor a check

If you PM me your contact data you used with support I can check the status. On the issue: Which firmware are you using at the moment? Current beta is still work in progress but I will keep you updated here on the state.

I Stephan, I’m using 2.4.5… it’s a normal installation bridge and Nuki 2.0. Experienced now 3 times an offline status, where you can’t anymore open the door - only by the key. The only solution is to pull off the batteries and then it works again.


Hi and thanks for your feedback.
I already mailed two couples of debug logs (app and bridge). One generic and One right After diaconnection.
I eliminated all integrations (Alexa, iftt, homeassistant) Just to have a clean situation .
But It still happens.
Also tried to change android bridge phone .

If i remove batteries and leave It alone without integrations It seems to stay online.
As soon as I interact via web.nuki io ti do anything (open close…) It does the operation and then goes offline.

Can you access logs sent to support?

Bt signal dismal but i do not think It Is thusbthe probelm . Connection Is s Lost in interaction

Software versions of nuki software Is the latest public.

wondering why it takes so long to fix this issues as there are many people if the offline issue.
We are all not looking for a beta version - make an official fix please

1 Like

Hi, I also have the simillar problem. When I go to App the lock is Loading very long, than I can put SETTINGS, go to Connection Status, than Disconnect Brigde, than Try to connect and after it it start to work. It work but not so long. The lock more is Offline than online. I mount it for my client and She is not happy for tjis product. Try to fix it fast.
I also tried to wrote to support - any reply.

I believe that problem is with Nuki Brodge, not in Firmware of lock.
I have lock with firmware 2.3.11 and it was working very good with Bridge 47/2018. Now I tried to conect lock with Bridge 10/2019 and there is a problem, the lock is Offline.
Whats is wrong with Bridge from 2019?

This is not a Bridge, I changed it and it still dosen’t work.

1 Like

Surprisingly, silent and no feedback -:frowning:

@matt Sorry if you didn’t get feedback from our support yet. I can’t see status of tickets there.
Regarding the Bridge where have been some updates (beta and public) lately which roll out automatically.
Regarding Smart Lock firmware, where will be a new public version soon, but we can’t roll out updates as easily as with the Bridge, as a manual interaction is neccessary. That’s why we ask users with current issues to go for Beta to for faster access to fixes.
And, yes, even if our support feels slow and unresponsive to you please keep them updated with your issues and logs files to help us solve your issues.


Just two quick things from my experience with this issue - nuki offline.

  1. Try and replace the physical Nuki Bridge with the Nuki Software Bridge android app ( that you install on an old phone and leave it within range. This way you can confirm/eliminate the physical bridge as the culprit. Don’t forget to disable Battery Optimisation for the Nuki Software Bridge android app and activate “Bluetooth restart in case of an error” and “AutoConnect” in the app. You can further optimize this by also inserting a SIM card in the phone and using a mobile data connection; this way you can eliminate any possible problem with your home WiFi such as misconfigured or defective routers, firewalls, shaby internet connections, what not. This is not an assumption that Nuki is not be blamed or that you do something wrong: it’s simply an easy test to eliminate as many possible problems as you can.

  2. One thing that happened to me was that i kept seeing not many, but a few Nuki offline situations. In one such situation i had to quickly open the door remotely for somebody. On my phone Nuki was showing offline so i grabed my wife’s phone. With my wife’s phone it worked instantly. But on my phone it still showed “Nuki offline”. It was then when i realized that i have a DNS based ad blocker on my phone which somehow interfered. I deactivated it and got back Nuki access instantly. Kept following the situation by activating/deactivating the DNS based ad blocker and checking on Nuki: sometimes it can access it just fine, sometimes not at all, but when i deactivate my adblocker it ALWAYS works. Now this is about the phone app but i am thinking that if i setup such an adblocker on a router level in the same location where the smart lock is this could just as well interfere with the remote access. Try not to use any very specific DNS settings - like OpenDNS, or parental controls, or stuff that implicitly tries to protect your network, because even if minimally configured or left with default settings it could block access.

I am not saying this is what causes the offline problems for you guys, but i thought i’d share my experience, maybe it helps anyone.

Kind regards.

An other day, where the Nuki goes offline. Sorry, product is useless as the trust is gone

It would be interesting to find out if it’s a remote access problem or a smart lock problem. There are two things you could try, if willing:

  1. if possible, when you are away and Nuki shows offline, IF you have somebody at home (father, mother, wife, husband, whatever) you could ask them to try and access the smart lock through bluetooth.
  2. reset the bridge and during initial setup enable developer mode and note down the IP, Port and API token. Then if Nuki goes offline again log in remotely to your home network and try to reach the bridge on your LAN ( - see the /info command).

The basic idea is to find the right culprit. It may be the bridge, the smart lock, both or something completely unrelated to Nuki. The only solution is a step by step approach and elimination.

Hi Johannes,

thanks for the try. On point 1, I can confirm that the Nuki is offline and not available through Bluetooth.

Waiting on the event, when it goes again offline to test point 2.
Will keep you updated.

12 Days no reply from Support.
This is not acceptable.
Even If, as I hope, it is a small part of customers that have this problem you should provide then a solution or at least a valid workaround.

This is not acceptable and, as in the same way I provided positive feedback on the many automation blogs and fora I am in at international level, I will start provide negative feeedback from now as it is neither solved nor taken in proper consideration from a customer care point of view.

I am sorry but I had all patience and offered collaboration. In exchange I received slow feedback (if any) and no solution.
I am not talking of this forum were there is no SLA and of which I know the limitations but of official customer support.