Smart Lock (4th generation) Firmware Beta 4.2.x

Smart Lock (4th generation) Updates

Smart Lock Beta 4.2.0

  • Bugfixes and stability improvements

Smart Lock Beta 4.2.1

  • Wi-Fi and MQTT improvements
  • Performance improvements and bug fixes

Smart Lock Beta 4.2.3

  • Update to Matter 1.2
    • The Matter Standard 1.2 distinguishes between unlocking and opening the door. With this firmware update, you can unlock your door without pulling the latch.
      This new feature is for now only available in case Home Assistant is used as a Matter Hub.
  • Beta support for Panic Doors, similar to how it is available on Smart Lock 3.0
  • Performance improvements and bug fixes
    • Improvements for Auto Lock in combination with the Nuki Door Sensor: Auto Lock now locks the door after the set time period only if the door is closed. If the door stays open, Auto Lock will lock the door after 30 minutes.
    • Improvements on the overall power consumption of the Smart Lock Pro.
    • Manually performed unlatch is displayed correctly again in the acitivty log.

Smart Lock Beta 4.2.4

  • Performance improvements and bug fixes
    • Reduced power consumptions due to improved adaptive BLE advertising intervals and improved WiFi connection handling
    • Enhanced WiFi reconnect capabilities

Smart Lock Beta 4.2.5

  • Performance improvements and bug fixes
    • MQTT improvements
    • Reduced power consumption during unlatch action
4 Likes

I can see available a 4.1.8 but not the 4.2 :face_with_monocle:

Done, now there is the 4.2. Updated.

With version 4.2, the nuki remote app with thread does not work for me. It only works through home assistant.


It works now, I have disconnected the remote switch and reconnected and everything is ok.

While matter usually always work pretty good when triggered via home assistant, offline still gets offline via app.

Seem to be somethinf related to sleep or powersave featurein the Nuki, because when you trigger the nuki via matter, for example force a block and led flashes, Nuki is again online for a few time.

1 Like

It doesn’t work, it disconnects and takes a long time to connect. My family opens with a key.

Hi, is it possible to use mqtt via matter? → tested and it works

With mqtt works really very well with HA, it has more entities and works even if matter addon is turned off (thread → nat64).

I do not know why but the online works pretty well during the morning, but after midday it starts to fail. Could be anything related to nuki servers?

Thanks!

Online crashes (matter+online) after using the app and doing an action like block or unblock.

It comes back if Nuki is restarted (pulling out batteries and inserting them again).

Matter and mqtt is still working and reporting.

1 Like

I guess you mean lock and unlock action with the Nuki App?

What do you mean with “online crashes”?
Is your Smart Lock connected via WiFi to the Nuki servers or via Thread/Matter?

Hi Jurgen, it is connected online via matter.

With crashes I mean that online stops working, but matter still works.

Online also gets repaired if you turn in off and on again in the matter section.

I confirm the same issue of @Toni_CB

1 Like

Same problem, when you remove the batteries it works again for a few minutes and then it disconnects and the Nuki app does not work remotely.

1 Like

Can report the same issue. Happening regularly. Regardless of whether you are also connected directly to the lock via BT. As soon as matter disconnects, the app won’t connect or ‘hangs’. If you take the batteries out to reboot the lock it corrects itself and works properly for a little while but not for long. Occasionally I have been able to toggle remote access on and off in the app which also fixes the issue. But most times, once it happens, the app won’t connect at all even with a BT connection.

2 Likes

Please let us know a little bit more about your system environment:

Which Matter/Thread hub(s) do you use?
What’s the distance from the closest Matter router to the Smart Lock?

I have one Apple Home Pod Mini as border router and the distanze is about 5mt (without obstacles)

The closest matter hubs are

HomePod 2 - about 2.5 meters away
HomePod mini - about 2 meters away

Plus I have the following additional matter hubs

Apple TV 4K x 2
HomePod 2 x 2
HomePod mini x 2

Plus a couple of Eve devices that act as Thread routers

1 Like

I have the standard Nuki 4 by the way and paid the £45 unlock fee for remote access

1 Like

I have home assistant with raspberry pi 3b, 5 meters away without obstacles. I have tried with raspberry pi 5 and it does the same. With home assistant and matter locally it never disconnects, it works perfectly. Only the remote is disconnected from the Nuki app

1 Like