Smart Lock 3.10.x Beta

That would be great, if the MQTT issue would be fixed soon. 3.9.5 really crashed it

3.10 actually

Glad im reading this. Currently in discussion with support about wifi issues since 3.9.5 and it looks like im wasting my time as its firmware related.

Im not even in the beta program so how has such an unstable release made it through?

Still having issues with the smart lock pro 3.0 loosing wifi connection using Ubiquiti access points. Back to using a Nuki bridge which is stable.

Nuki is pretty stable now with 3.10 . No Wifi-problems etc. mqtt is also working as expected. Only the mqtt-reconnect-time after a wifi-reconnect should be reduced. It could trigger right after wifi-reconnect.

…and if the nuki could also work with 192.167.X.X-Range in LAN-environment…it would be great

This is not an official private network IP and will therefore remain blocked.

@Juergen In the FAQ the question about Wi-Fi stability specifies both 3 and 4th gen in the title.
Does it mean the feature when setting power saving to fast is now also applicable to SL3pro?


1 Like

When do you expect to deliver the new Firmware ? I also joined the beta-tester programm a couple of days ago, but still have not received the new firmware. This Wifi/MQTT Bug really gets annoying

KO here too with 3.10…connection is getting on and off and calibration is no more calibrating the lock correctly.

When is expected new beta firmware?

Here, same problems with MQTT

Is posible a downgrade to 3.8 or earlier?
It did work flawless since I bought it but then, I upgraded firmware and all this nightmare started.

Now, upgrading to all betas to have the same issue

1 Like

MQTT completly broken with 3.9.5

I received the 3.10.1 today incl. Wifi & MQTT improvements. As I don‘t have issue with Wifi and don‘t using MQTT, I can‘t comment on this fix.

1 Like

Everyone with problems with MQTT and 3.9.5/3.10.0, please report back if 3.10.1 fixes your problems.

If not, please provide are short description about your system architecture and the problems you have rather than just writing “it’s broken” (which is not very helpful especially when trying to find the cause of a problem which does not affect everyone but only a subset of users).

1 Like

First at all, my apoligies. You’re right, just complaining doesn’t help to anyone.

Anyway, last night I installed 3.10.1 and, don’t want to say it too loud but seems this is working much better.

Attaching a history of the lock in HA where you can see clearly when the new firmware was installed.

I will keep an eye and revert back


1 Like

I just installed the 3.10.1 on my two devices and hope the WiFi and MQTT problems are finally fixed. The 3.10.0 was as terrible as the 3.9.5.

I have a setup with two Nuki 3.0 Pro, WiFi roaming and home automation using Home Assistant. I hope I can report it as fixed…

—- Kevin

Problem with WiFi disconnects still not solved. :slightly_frowning_face:

Hello Jurgen and thank you for your answer.
It is difficult to partecipate in a beta program without knowing in detail what changes in every beta release, without any possibilities of rolling back in case of problems and without a well structured way to diagnose problems and send you the details you need.

I think that nobody here buys smartlock only for testing so our evidence should be of some help for you to get the app and the software better and better.

I will try 3.10.1 asap and let you know if MQTT is resolved. Anyway, what kind of details do you need to diagnose? Logs? Timing? MQTT broker extractions?
About calibration problems that I do not had in previous versions, what kind of information can I give you to help diagnose the problem?

Help us to help you :slight_smile:
Thank you very much

Same anoyning issue here !

It seems better for now with 3.10.1, i will observe the connection: