[Smart Lock 2.0] Firmware 2.7.30 - Problem

Hi all!

After updating my Smart Lock 2.0 to the newest firmware 2.7.30 the Smart Lock needs much more time to open the door (turn the key) … it turns the key very slowly.
The batteries are nearly new, the resistance (does one say so, my english is bad) for turning the key is the same.

Is it a known problem?

Thanks and regards,

I have the same issue. Can anyone help?

1 Like

Hi @invidianer and @milton,

Please provide more details for the stated behavior:

  • What batteries are you using / were you using before?
  • What do you mean with the resistance? Do you mean the battery report in the app?
  • What do you mean with “nearly new” batteries? Have you tried to insert “completely new” batteries?

Thanks and best regards


The batteries that came with the Lock (only 3 weeks „old“).
I checked them with a battery tester, they are in perfect condition.
I mean the power that is needed to turn the key.

I changed nothing (!), only installed the Firmware-Update. I do not believe it is coincidence.

Same here. I am using the same batteries as before. In my case there is another strange behavior. The unlock and lock functions were swapped. The device locks when I tap to unlock, and vice versa. This messes with a number of features, like auto-lock / auto-unlock.

Same here. Right after updating to 2.7.30, I had to replace the alkaline batteries (many weeks old, here). This happened to both my locks.

Same effect noticed here: Same batteries, same door lock, … but it turns much slower now (which I’m fine with when it comes to locking, but unlocking makes me wait outside even longer now).

Same here. Updated Lock and Opener, Lock turns much slower now which is painful when waiting outside. (On the plus side, it makes less noise, which is great at later hours.)

I have a problem with my lock too. Now the second time I had to go to the house through garage because lock was offline. Not even with bluetooth.
First time I take out the batteries and replaced it and lock worked for 3-4 days ok. And then again … offline.
With previous firmware it was OK.

Same here, and in my case it takes much longer for the nuki to react via bluetooth (newest IOS APP). Somtimes it takes over 10 seconds. If you send the open-order twice (in that time) it open the latch a second time right after the first time (which makes no sense).

Before the update I didn’t see that behavior.


A new Beta Firmware 2.8.2 has been created for Smart Lock 2.0, which should fix the performance related issues from this thread:

If you need any assistance for getting this version onto your Smart Lock 2.0 feel free to reach out to me via PM.

Please share your findings with that version - Thanks.

1 Like

Can someone confirm that the problem has gone with Firmware 2.8.2 (or newer, 2.8.15 is available)?
I would update, if the problem definitely has gone?

(I was able to exchange the Lock that did not work properly with 2.7.30 at Amazon, because a downgrade to 2.6.4 was not possible and I am still running 2.6.4 now).

Update your software

I did.