Smack Lock version 2.10.8 Transfer failed / firmware update fails

I bought a new Nuki Smart Lock and want to update firmware. It is connect both to my iPhone via Bluetooth as well as towards the Nuki Hub with Bluetooth and WiFi. The connection strength and quality is excellent and of no issue.

When I use the Nuki App to update the firmware it downloads the Firmware and immediately switches to “Transfer failed”. Even a restart as well as unpowering (removing the batteries for 15 seconds) does not solve the issue.

What can I do now?

Thanks and with greetings from Berlin


Same problem here. Bought my Nuki incl. bridge a couple of days ago and cannot update to the newest firmware. I’m getting the same error. So seems to be a general issue.
I tried to transfer the update via 2 different Android devices, with an iPhone device and directly via the bridge (endpoint /fwupdate). None of them seem to work.

For me the problem goes even further. With the old FW on the Nuki, after locking or unlocking the door in 90% of the cases the motor doesn’t get released, which means I cannot unlock the door with a normal key. That makes for me the Nuki unfortunately at the moment unusable.
Hopefully this problem gets solved with the FW update, but with the FW update failing, this is a bit disappointing currently.

Hope to get some support from the Nuki team after the public holidays.

You both seem to have individual & different issues. Please contact customer support through the Nuki App (Menu > Help > Contact customer support).

If you have problems with firmware updates through the Smartphone the easiest solution is to let the bridge do the work. Just make sure that “Automatic updates” is activated in the Administration > Firmware update section. After 1-2 nights the update should be automatically installed.

Hi Jürgen,

thanks for your fast reply. I have contacted also in parallel already the support via the according app menu. I tried the automatic update feature as well without success. Is the automatic update feature doing something different compared to the /fwupdate endpoint on the bridge? Tried this command with the according token also already serveral times. Unfortunately with no success. Current FW is still on 2.8.15.

But of course we can sort that our individually via PM/email/support request.


same Problem here! It is not possible to install the new firmware. I tried several devices and also over the bridge in automatic mode with no success. Actually I am waiting for Feedback from the support. I ordered directly from nuki and I am very frustrated that they shipping the hardware with this bug. I am feeling like a beta user - what a f…!

Please contact our support via the Nuki App Menu > Help > Contact customer support. They can help you.

Same problem here. Any solution?

I’m in the same situation. I bought lNuki Smart Lock 2.0 combo new and installed it on the 27th and I have not been able to install firmware 2.10.8 in any way. I have opened several incidents with technical support via e-Mail and through the App and I am waiting for some kind of solution to be communicated to me.

I don’t know if it has to do with the same problem, but when I want him to open the door by pulling the knob, I have to ask him up to 3 times to get it.

1 Like

we are currently working on the solution for the stated issue with the firmware update on the Smart Lock 2.0.

In the meanwhile please contact our support for further assistance:


Okay and thank you very much for your attention.

But the truth is that I am very lost and I do not know exactly what help to request, since until you correct the failure, I do not know how to continue.

Thank you very much and sorry for the inconveniente.

I will keep an eye on the news

problem solved - thank you!