SL4P erratic battery percentage and draining

I’m a long time Nuki user and have owned a SL1, SL2 SL3P and now a SL4P. For most of the time I’m a happy users but I’m not too delighted about the SL4P. I kind of miss my SL3P.

The main issue I’m experiencing is erratic battery percentage and in general a battery drain. The percentage jumps up and down sometimes even with by 20%. Also the battery consumption seems extremely high compared to my previous Nuki’s. I dont have actual numbers but with my SL3P connected over MQTT I’m guessing I would at least get 3 months of usage and I never experience erratic battery levels being reported. Now with the SL4P I’m lucky if I get 3 weeks. Nothing has changed in my setup. Still the same WiFi network, stil connected to MQTT. I do experience an issue with the SL4P from time to time where the motor blocks when unlatching and the door can not be closed anymore without manual interaction. I dont think this is related to the erratic battery level and drain though as that happens even without these blockages.

The graph included below shows the erratic behaviour and battery drain. The only time I charged the battery was on the first of april (I kid you not). In the periode before that there was a lot of jumps and I after disconnecting the charger this morning the battery level was 100% till the evening and then within 4 houts it went from 100% to 89%. That’s 11%! And it keeps on draining, my guess is I will have to recharge within a day.

How to troubleshoot this behaviour and get more out of my Nuki battery.

Not sure if it’s related but when trying to create a battery report I’m getting an error that getting information about the device was not possible because it was unable to connect the device (I’m connected to the device over WiFi and Bluetooth while trying).

1 Like

It seems to be getting worse. Overnight between 21:00 and 07:00 the lock dropped 9% without even doing anything.

This is insane. Another 40% drop in 14 hours. The last spike is after pulling the battery pack in the hope that fixes the drain. But I do not even dare to leave the house without it also hooking up to a power bank, so the last 15 minutes of this graph it has been charging.

And this is what I get when trying to create a battery report from the app or try and open a help page. This is on app version 2024.4.1.

And here are some generic details.

Please help!

Update to 4.2.6 and check if the battery draining issue remains. Make sure that Battery saving is set to automatic (and not to fast).
If it remains, deactivate MQTT. If that still does not resolve it, join the beta program so that we get more logs and can have a more detailed view of what’s going on.

The jumpiness in battery percentage that you observe should mostly go away with the 4.2.6. Setting battery detection from automatic to Power Pack might help there too.

Ok, I just requested beta access.

Double checked and it’s set to automatic already.

I hope to avoid that as this is the reason I upgrade from a SL2 to a SL3 and now my SL4P. I’ll await beta access and the beta firmware first.

Ok, changed that to be fixed on battery pack.

One solution…





I wouldn’t call that a solution but a workaround. For now it seems updating to beta firmware 4.3.1 has solved the issue of the drain. It’s been 100% for a couple of days now. Then in itself is a little suspicious but I’ll see what the next value will be.

Next on the list is an issue with the SLP4 that when opening the door the motor blocks when it’s fully unlatched instead of returning to the unlocked position. It then can not be closed anymore without manual interaction. But I’ll post a seperate topic about that when I have further analysed it.

You are right, it’s a workaround and happy to have it :wink: it would be even better if I could disable the blinking of the recharging light that goes on and off while charging. Happily this happens only when charging so it’s not blinking all the time. I have also found a workaround for that one as you can see for the close-up pictures :blush: