SL4 Pro does not work with MQTT

I have been trying to make my SL4 Pro work with MQTT for a couple of weeks now, and I am unuseful.
Please note that I am new to MQTT (It’s actually my only device) but used to other smart home protocols.
Initially, running the production firmware, I was able to connect to the broker (Mosquitto running on Unraid) and the lock was auto discovered by Home Assistant (Running the docker version on Unraid).
Everything worked normally for a few hours before becoming unavailable. I would then re-enter the credential for the broker in the nuki app, and it would work again for a couple of hours before becoming unavailable again, etc.
I tried to use another mosquitto container, but I was then completely unable to connect to the broker. I was able to connect an ESP32 running nukihub using the same credentials, and it has proven more reliable than the built-in version… But I would rather run everything off the lock (It has at least the advantage to be slightly faster).
Seeing that a lot of people are complaining about this issue and that some work is being done on this, I joined the beta program and tried again. But I am still unable to connect to the broker. This is the message I get in the broker’s log:
2024-01-03T17:07:15: New client connected from [IP:PORT] as SL3P_***** (p2, c1, k300, u’[USERNAME]').
So the lock is indeed connecting, and the broker is accepting the connection, but nothing happens in the app and the lock is not publishing any message. This is then followed by either:
2024-01-03T17:14:51: Client SL3P_***** has exceeded timeout, disconnecting.
After a few minutes or immediately by:
2024-01-03T17:17:05: Client SL3P_***** closed its connection.
Thanks for your help.