Since Smartlock Update to 2.7.20 Homekit problems

Hey there!
I updated the Smartlock V2.0 to new FW 2.7.20 when it came out…now I have problem with Smartlock “not responding” pops up in Homekit and I cant use automation sequences anymore - also Siri says “smart lock not responding - please check”.
But when using the NUKI App it works!
I tried to change batteries, delete device in Homekit, restarted bridge and so on.
Nothing works.
Any clue whats wrong here?
For testing purposes i tried it using homebridge via
and here it works?! Also siri works this way…

Please try to remove the HomeKit Pairing inside the Nuki App (Settings > Administration > HomeKit) and pair the Nuki afterwards again with HomeKit.

Hi. Can you give some news. Because in my Nuki App IOS, i have the update, but i don’t want to do if problem whit Hommekit… I want to be sure before update. Thanks.

Sorry for late response…
I found the problem…
@Jeff it was because I got a new lowboad with aluminium enclosure - thus Bluetooth connection to my lock didnt work anymore.
Thats why it continued to work via homebridge!
So you can savely update :-9