Problem found with Nuki Android App and watches with Tizen OS

I have opened on December 2 a support ticket 246425 with this question, but yet don´t have a solution…

Description of the problem: If we do not open the Nuki App on the phone the device does not appear on the Galaxy Watch 3 with a Note 10 + (Android 12) or on a Galaxy Active 2 with a Note 20 Ultra (Android 13), both watches have Tizen OS ( and stay with the messages “connecting…” or “smatphone not available…”.
Video of the problem: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.
NOTE: In the video you can see how the application has enabled the NO RESTRICTED option, which allows the application to be in the background without restrictions, it is the first thing I show in the video.

I have downloaded and tried all versions of Nuki App until September 2022 and what I suspected has happened:

  • V2022.12.1: Does not work without the App open.
  • V2022.11.2: Does not work without the App open.
  • V2022.11.1: Does not work without the App open.
  • V2022.10.1: Does not work without the App open.
  • V2022.9.1: Works correctly with the App closed.

Since V2022.10.1 the background activity of the Nuki App has stopped working correctly, or at least with regard to the connection of the Tizen OS watch with the application, since if it is not open on the phone it does not work.

At the moment I’m going to use version V2022.9.1 which is the one that works correctly with the Tizen OS watchs, but I hope that in future versions you correct this defect so that I can update to the latest version…


Thank you for the detailed feedback. We were not able to reproduce the issue yet, nor did other users report it. We’ll have a closer look at it, but can’t promise any timing for it nor if we finally find something as it could also be an individual issue with your setup.

I have the same problem, with the latest update it doesn’t work if you don’t have the application open on the phone.
conclusion, it is useless

This problem persists today, I recommend everyone who has a Galaxy Watch with Tizen OS to install V2022.9.1 version on the Android mobile, with that version of Nuki App the Watch will work correctly. I bought a Galaxy Watch 4 Classic that works with Wear OS and for connects correctly I need to have the latest version of Nuki in my Android mobile, but if I put my Galaxy Watch 3 only works correctly if I install the V2022.9.1 version…

It has nothing to do with your watches or phones, nor is it a configuration problem, it is only a problem of the Nuki App, and at the moment it is still not solved despite opening several tickets and having updated the App on numerous occasions, but since V2022.10.1 version the connection with the watches with Tizen OS is broken and only works if you have the Nuki App open on the phone.