OpenWrt router & settings for Nuki Smart Lock

If you search for an (additional) Wi-Fi access point or repeater for your Smart Lock 3.0 Pro (with integrated Wi-Fi) you might have a look at the D-Link DAP-X1860 A1.

While the stock firmware is not very reliable, the router supports the open source firmware OpenWrt, which transforms it into a very reliable access point with record low power consumption of the Smart Lock at an attractive, low price point.

Installing OpenWrt on a DAP-X1860

Configuration hints:

  • Connect the AP via ethernet cable to your router or internet uplink. You can use the DAP-X1860s LAN port if you establish a bridged network or the WAN port if you create a NATed network. If you use it as a wireless repeater, use the 5GHz band for the wireless uplink to your main Wi-Fi. Do not use the 2,4GHz band to repeat your existing Wi-Fi as this will generate interferences on the 2,4GHz band, which can significantly increase the power consumption of your Smart Lock.
  • Go to Status > Channel Analysis and scan for other 2,4GHz networks. Select from channels 1, 6, 11 or 13 the one with the lowest usage.
  • Setup a wireless network on this channel for your Smart Lock (or any other IOT device), with the following settings:

  • Connect your Smart Lock to the newly created WLAN.


1 Like

Instead of repeater, may i suggest to use real AP with OpenWRT,
in my case i use a “low cost” AP ASUS RT-AX53U WiFi6 AX1800.

You can create several wlan SSID on each band 2.4 and/or 5 Gz,
with one SSID for your home usage, and one dedicated to Nuki
with specific parameters. Check OpenWrt WiFi config,
ap isolate, disassoc_low_ack, skip_inactivity_poll

something like:

config wifi-iface ‘default_radio01’
option device ‘radio0’
option network ‘lan’
option mode ‘ap’
option ssid ‘nuki’
option encryption ‘psk2+aes’
option key ‘SpecificNukiPassword’
option channel ‘auto’
option channels ‘3-5 7-9 11-13’
option isolate ‘1’
option disassoc_low_ack ‘0’
option skip_inactivity_poll ‘1’

I will test this next week on new upcoming Smart Lock 3.0 Pro.

Not all parameter’s are available in OpenWRT luci web interface.

You can of course do that as well. It will create a (not necessary) double NAT and shield the Smart Lock internally from the network, but both things should not create problems and should work fine.

All my home AP are wired and setup in bridge mode, there’s no double NAT only one GW doing NAT, DHCP, and all other network stuff.
Can this decrease battery life with Smart Lock Pro in WiFi ?

Depends on what’s going on in your network.

The ideal environment (for every WiFi device) is a clean network, with no other clients and no other network on the same Wifi channel. Simply said: Less traffic = less wakeups / retransmitts = less energy usage (& more speed).

When moving away from the ideal scenario, the next best thing to have is a shared network, with a clean channel. After that comes shared network on a clean channel and after that shared network with shared channel.

In addition to that you can have some specific clients causing harm. E.g. one device constantly sending unidirected packages to the Smart Lock (e.g. a ping), would also drain it’s battery rapidly.

Except the broadcast (for DHCP) i can filter traffic on AP with decicated nuki SSID.
To avoid DHCP traffic, can i setup smart lock with static IP ? otherwise can i use really long DHCP lease-time to avoid traffic ? > 1d
All iOT on my network have both out/in traffic filter, did you provide internet IP/CIDR network that must communicate with smart lock ?

That is not necessary. DHCP for the Smart Lock itself causes very little traffic and broadcasts are typically ignored and do not cause additional battery drain.

No, we can not guarantee a specific IP-range for the time beeing and can not provide such a range.