openHAB Integration

Nuki binding for openHAB2:

I am using Nuki Bridge V2 with firmware 2.1.37 and it seems that the openHAB Binding stops to work after using the NUKI App on the mobile phone? is the App somehow overwriting any existing API callbacks? @Stephan

additionally the binding also does not seem to reflect to acutal state of the lock, for example if the lock is manipulated directly on the hardware or via the app the openhab channel does not seem to update its state? therefore only if the lock is used over openHAB itself the binding shows the proper state

No, the App has nothing to do wih the API callbacks.

Did you check the status of the callbacks and see any changes/lost ones? (https://developer.nuki.io/page/nuki-bridge-http-api-180/4/#heading--callback-list)

They could only be overwritten manually or by another itegration.

Mmh, maybe callbacks are not set correctly at all? Please check as described in the link I sent above.

ok perhaps there is a problem in the openhab binding itself, I have set “manageCallback=true” therefore the binding should take care by itself… strange…

is it possible that the API for callback registration changed over time? it seems that the callback list is empty on the lock, I have to check the source code on openHAB binding how the callback is registered right now @Stephan

I just tested it with a Bridge with FW 2.2.0 (latest Beta) here and Callbacks are working fine for me (https://developer.nuki.io/page/nuki-bridge-http-api-180/4/#heading--callback-add) and exactly the same as in older versions.

Only thing you have to keep in mind is, that it only supports http:// URLs and the API will through an error if you try to add a https:// URL for a callback.

Hi,

I have also an issue with the callbacks. I do not get any callback of the lock states.

With http://NUKI_IP:8080/callback/list?token=XXXX I got the following response: {“callbacks”: [{“id”: 0, “url”: “http://OPENHAB_IP:8081/nuki/bcb”}]}

With http://OPENHAB_IP:8081/nuki/bcb I got the following response: {“status”:“Invalid BCB-Request!”}

And in the openhab logs I found the following error messages:
2019-04-13 11:26:38.891 [ERROR] [internal.dataexchange.NukiApiServlet] - Could not create BridgeApiLockStateRequestDto from BCB-Request! Message[null]

2019-04-13 11:26:38.899 [ERROR] [internal.dataexchange.NukiApiServlet] - requestContent[]

2019-04-13 11:26:38.902 [ERROR] [internal.dataexchange.NukiApiServlet] - Could not handle Bridge CallBack Request - Discarding!

2019-04-13 11:26:38.904 [ERROR] [internal.dataexchange.NukiApiServlet] - Please report a bug, if this request was done by the Nuki Bridge!

Note: Manage Nuki Bridge Callback ist set to ON

You mean you directyl opened the URL?
Then the error message makes sense because you triggerd a callback without content.

The callback itself looks fine to me. So if the lock status change you still see such an error in the open HAB logs or is there just nothing?

Sadly log files for the bridge are still only available for the old hardware-revision, so if you got a new one its a bit tricky to debug.

Do you use Nuki Web and are status updates pushed there immediatly?

Hi,

I got 100% same issue as ssaado. Callbacks only works when lock changes are initiated by Openhab.
Changes initiated by the nuki app or keypad or bluetooth access do not trigger any callbacks.
The callback list seems ok: {“callbacks”: [{“id”: 0, “url”: “http://openhabian:8080/nuki/bcb”}]} this is the only callback installed.
This is a Nuki V2.

And also got the bridge api error:
2019-04-28 16:04:06.707 [ERROR] [internal.dataexchange.NukiApiServlet] - Could not create BridgeApiLockStateRequestDto from BCB-Request! Message[null]

2019-04-28 16:04:06.714 [ERROR] [internal.dataexchange.NukiApiServlet] - requestContent[]

2019-04-28 16:04:06.718 [ERROR] [internal.dataexchange.NukiApiServlet] - Could not handle Bridge CallBack Request - Discarding!

2019-04-28 16:04:06.723 [ERROR] [internal.dataexchange.NukiApiServlet] - Please report a bug, if this request was done by the Nuki Bridge!

Also the question for you?

Was the second callback initiiated from Nuki or did you manually open the callback URL?

Bc. the error seems to inidicate an empty/wrong format response which makes not a lot of sense if it works other times. (Else the callbacks would never work.)

If callbacks really never work (and the one you posted looks correct to me) it could also be some problem with your Bridge. Which Bridge Firmware are you running on atm?

Hi,

I have the latest public version 1.11.4. I tried to simulate this error, using the Nuki App and using the openhab binding, but did not get this error anymore. Callbacks are still not working.

Mmh, 1.11.4 (and newer) has no issues with callbacks (in general) here for me with Smart Lock 2.0.
Maybe it is something Openhab specific. Could you try to see if Callbacks to other URLs work for you? Then best contact the developer of the openhab binding.
Else I will try to investigate further on our side.

I added two extra call backs: one for Openhab and for Loxone:
{“callbacks”: [{“id”: 0, “url”: “http://IP:8080/nuki/bcb"},{"id”: 1, “url”: “http://IP:7777/dev/sps/io/Callback_Nuki/Pulse"},{"id”: 2, “url”: “http://IP:8080/rest/items/Nuki_Callback”}]}
None of them have been triggered.
Executing bridge commands via url like http://192.168.1.137:8080/callback/list?token=??? seems not always to work: HTTP 503 Unavailable. But after trying several times I get the correct response.

I did manage to get callbacks but the problem is the bridge being offline most of the time.
When I go to the connection status there is only a connection between smartphone and server and then full connection. I will experiment with the position of the bridge.

Thanks for your feedback and patience!
We did a lot of stress tests with the bridge lately and will push some updates which are supposed to stabilize a lot of this issues.

Please keep an eye on our Beta section here where I will update you when the new Beta firmware is available (the Bridge automatically updates 1 hour after reboot and then all subsequent 24 hours, so to update it is best left running for some time). If your bridge is not part of the Beta programm you can do this by following this steps:

If this version is stable for the beta users it will be provided as a public update as soon as possible.
After that update we hopefully can hunt down remaining issues with this easier (when other factors with persisting connectivity problems are ruled out).

unfortunately I cannot get the smartlock online in the OH binding
I use smartlock version 2.6.5. It is connected to my bridge. The bridge gets online but the smartlock not.
more details:
https://github.com/mkatter/openhab2-addons/issues/12

Hi Stephan - could you please hav a look at my problem (see above).
Thanks a lot