Opener push notifications extremely unreliable

Hello,

I bought the Opener because I wanted to get push notifications on my phone instead of the ringing of my intercom system. Unfortunately, the notifications are so unreliable that it cannot be used as intended, at least for now.

If I receive a push notification on my iPhone, they are always late (20-60 sec after ringing).
Most of the time I don’t receive any push notifications at all.
Today I got 3 notifications for a single ring.

On some days it works, but on most days it doesn’t.

The activity logs in the iOS app as well as on Nuki Web are always correct.

Opener FW Version: 1.6.3 Beta (same behaviour with stable and previous beta versions)
Bridge FW Version: 2.8.0
iOS App Version: 2.7.2
Intercom: Bticino BT-344502

Is there anything I could do?

Thanks!

4 Likes

Something happens today with the notifications, because I have stopped receiving notifications, door opening and closing, from other users when executing commands, etc. Everything is registered correctly, it seems that everything works correctly, but it does not launch notifications. notifications are activated in application.
Normally the notifications are almost instantaneous, but since yesterday I began to have delays in the notifications, even some did not send them, this afternoon, I have definitely stopped receiving.

I think we will have to wait to see if they fix

Just to be clear, this is not a temporary issue for me. It’s been like this since I bought the Opener about 3 months ago.

1 Like

Interestingly for me this has been going on for around a week for opener as well as the lock. Nothing will happen and then at one specific event all the late notifications will come. Freaked me out once when i got notification that fron door got opened at 3am.

1 Like

Same for me. The notifications are extremely unreliable.
Sometimes, I also get a notification when RTO is activated, but no one has actually ringed yet. It would be great if you guys looked into it, as this is an important use case for me

1 Like

Same here. The Nuki push notifications have been unreliable for me from the beginning for both, Lock and Opener.

I tried resetting everything an reinstalling the app a few times at the beginning.

I also often get push notifcations about someone opened the door manually hours later.
This really freaks the shit out of you when you’re not at home at that moment and you receive something like that for the first time.

Btw. I use dozens of apps that use push notifitions and I’ve never seen such frequent and huge delays like here.
Not sure what’s the problem with the Nuki servers…

The only reason why I kept the Opener, is that the bridge API finally supports local callbacks when someone rings the door.
The Bridge API is very fast, so the push notifications delay seems to be only related to the Nuki web servers.
On my smart home server I use the bridge callbacks to send myself notifications with Pushover.
These messages are almost instant and they never failed.

I still have the Nuki push notifications enabled additionally, to see if the problem is fixed at some time in the future.
But so far no luck…

same here! Opener notifications are ABSOLUTELY UNRELIABLE.
Even worst: they constantly trigger any IFTTT integration.
I have an IFTTT integration with Philips HUE so that when someone rings at the opener my lights blink.
Well, sometimes lights receive the ring notification HOURS later, sometimes (very often) the geo-fence notification triggers the IFTTT integration like if someone had rang the opener.

very disappointing.

Just joining the chorus here. Especially frustrated since mine is also connected to IFTTT. I have had issues for month too (and posted several threads about it without any solution). Very frustrating and feels like it shouldn’t be so complicated to fix - my old Nello never had any delays, it was instant.
The one thing I’ve felt have made it a little better is setting the opener to debug mode. But it’s still not realiable. Extremely frustrating and disappointing

1 Like

I can confirm the problems regarding push notifications for the opener and the lock. I also tried to use IFTTT and had the same issues. I now implemented Nuki directly into Home Assistant, that works fine as it directly talks to the API.

What I noticed is, that the problems only arise when using the bridge/cloud (so notifications via WiFi). This is of course mandatory for the Opener, but the auto-unlock notification for the lock (when I get close to my door) is instant. As I hear the lock opening I already notice my smartphone vibrating. I think this is because of the direct communication via Bluetooth.

In case of the opener: I did not get any notifications in the last weeks, I can confirm very late and double notifications at random times (hours) later.

1 Like

Thank you all for chiming in and confirming I’m not the only one having issues.

I must correct myself: In the last week the ring recognition didn’t work at all. No notifications and also an empty activity log. It only worked when auto unlock was armed.

This makes sense since these are probably “local notifications” and therefore they don’t require a remote notification service.

@Stephan @Juergen do you have any feedback on these issues? Are you guys looking into it?

I think you are on to something. My “Your opener is ready for auto unlock” notification always trigger. This gets trigger from my phones geolocation (not within wifi or bluetooth range of the bridge or lock). So that goes Phone -> Server -> Bridge -> Opener. Never any issues there, and auto unlock always work. But when I then unlock my door, Opener -> Bridge -> Server -> phone something goes wrong and I dont get an notification saying “Jesper auto unlocked the door”. presumably the error is somewhere between bridge and server or opener and bridge?

Yes, we’re looking into it. I sent requests for logs to the latest participants in this chat. Just sent them to you too.

3 Likes

Unlike many others, I do see all the entries in the logs, but receive 0 notification about anything opener-related (except the AutoUnlock when I am in gps radius).

1 Like

Looks like notifications are not enabled for the Opener. This is a different problem. Please contact our support via https://nuki.io/en/support-request/ or contact@nuki.io for more detailed information.

Just to throw my 2 cents into the mix (rather than create a completely new post for this as it seems to be a related/similar issue) - the opener notifications for me are generally reliable now (within around 5 seconds of the intercom button press).

However there is one consistent issue I have - for the first intercom press of the day, the Nuki notification is always significantly delayed (45-60 seconds after buzzer press). All intercom presses thereafter during the day are fine. I suspect the Nuki Opener is going into some kind of sleep mode overnight, which takes time to wake up from and causes this delay.

Edit - should probably add, this is with Nuki Opener firmware 1.6.2