Opener loses name and some settings, crashes in config

I have a Nuki Opener running fw 1.10.1. The following happened more or less suddenly, but at least without interaction from me:

  • Opener seemed to forget its security code, neither the saved security code nor the one I remember setting worked (e.g. when opening the Schedule)
  • Device Name became a series of unicode unknown character marks (<?>)
  • Setting a new Security Code works in Features & Configuration, without ever entering the old one?
  • In the Button, LED & Sound submenu, all settings got set to off (Bluetooth paioring, LED signal), and when I tap either switch, the Android view crashes
  • Activity Log disabled itself, but I can re-enable it

Additionally, but likely unrelated, the time zone shown in the Android app is wrong (Atlantic/Rekjavik instead of Europe/Berlin CEST).

This is not the first time this happened with an Opener of mine and I am at a loss as to what is going on. It feels very weird that the Opener would forget the security code and lock me out, but even weirder that it would just accept a new security code right after not accepting the old one.

Any pointers on how to debug this would be welcome, I tried enabling the debug mode but didn’t see any additional information in any logs.

1 Like

After some more debugging it looks like the internal storage got damaged somehow, whether through current shenanigans in the house wiring or low battery issues or what I don’t know, but e.g. the display name was set to null (null bytes only), some of the conditionals didn’t work right, etc. A full factory reset seems to have fixed the issue for now. However it’s not sustainable to randomly lose Opener functionality.

@ Nuki hardware team, is there some way I can read out the internal storage and debug deeper through the serial or debug port or do I need to start desoldering things?

1 Like