Opener compatibility with TCS ISW3030


I am having trouble setting up my opener to work with my door bell. While TCS is not (anymore?) officially supported in the list of manufacturers, I have found some resources that show that it should work:

TCS was apparently supported at some point which this pdf proves. However TCS cannot be picked from the manufacturer list in the Nuki app.

This guy on twitter was successful eventually after he got a replacement for his apparently broken opener:

And this google image search result shows that someone on this forum got the ISW3030 to work but struggled with the bell ring suppression. The thread seems to have been deleted though.

After a lot of googling it looks like the internal layout is identical to a Koch TC50, so i chose that device from the selectable devices.

I used the exact wiring as the twitter guy has, which is identical to the instructions for the Koch TC50.

According to this website, the TCS ISW3030 is compatible with the Nuki Opener.

Can someone point me in the right direction? It feels like I’m very close to a solution. This is the inside of the ISW3030:

I re-did the wiring 3 times to rule out any issues with the wiring or other connectivity issues. Every time I finish the setup, the same error screen tells me “Die Installation der Gegensprechanlange entspricht nicht dem Standard”.

If I can help to expand the list of supported devices, I’d be happy to help. Let me know what info I should provide.

I got it to work. I used the wiring from the google image result, taking the wire from b to join with yellow and red, then putting orange and green to b. Then also adding the black wire to a.

The current setup gets me through some steps of the setup but fails on the “open on ring” step, which is weird.

Hi! Also ich habe eine TCS-ISW-3030, und TCS ist nach wie vor in der Kompatibilitätsliste von Nuki-Opener enthalten!? Bei mir funktioniert auch alles ohne Einschränkungen!? Wo hackt es den genau, - welche verkabelung wurde getestet!?

1 Like

Where do you see TCS in the list? It’s not showing up in this list for me. It’s also not in the list when I choose the model in the app during the setup:

This is the current wiring:

The ports are labeled E, P, b, a from top to bottom.
Orange+green are in b, the wire that originally was in b is now in the clamp/clip with yellow+red. Black was added to a.

With this wiring I get some progress:
When setting up the opener, the app asks me to use the door opener on the ISW3030. This is recognized correctly. Then I need to go downstairs to the door and ring. That is also recognized correctly. Then I need to press the “open the door” button in the setup dialog and the door is actually opened for me.

The next step is where it fails: The setup process sets the opener to “Ring to Open”. When i ring (using the doorbell), my phone vibrates, so the Opener definitely recognizes that, but the door is not being opened for me. That is where I am stuck. If I tell the app “this didnt work”, then I need to restart that whole setup process. I did that 5 times now, also restarting the opener and the app and so on.
If I lie to the app and confirm that the door was opened, at least I can finish the setup process, but the Opener still does not open the door. Also all I can do in the app is set that door to “ring to open”, I cannot open it from my phone.

What a mess, really. I also bought a bridge and the Lock3.0 and the devices are “not available” from Alexa. Expected more for my money.

@Rose_Languste: Can you show me your wiring? And can you take a look in your app that your Opener is really configured as a TCS ISW 3030? I am really surprised that I cannot pick that manufacturer/model when it was apparently available to you…

Hi! Yes right, I started a new thread where I asked why they removed TCS!? Before a few months I got a new intercom, - the TCS ISW 3030, and I looked up the Compatibility-List before installing, abd TCS was present with much models, and I have setup the opener with the steps what the app showed me specifically for TCS ISW 3030, and it works fully since then!? AND I have the solution to your issue, because I had exactly the same, and it is very easy to solve!!! Go through the setup process as you described before, lie to the app in the last step to get through, when you are through, go into the app - opener - settings - administration, and set the delay for opening to 3-Seconds, and then try again ring to open, it should work now! - This has the reason that, when you ring downstairs the visitor gets a little tütlütlüt tone, for that the visitor knows he has successfully rang, in this time where this tone occurs, the bus is occupied and no other commands are getting executed, and with stock settings the opener sends the opening signal instantly but this opening command doesn’t get executed, because the bus is occupied because the tone is not finished yet, BUT with 3-Seconds opening delay, the opener sends the opening command precisely after the tone is over, and the magic happens and the opening mechanism goes active, also with ring to open! Let me know, if this solved the issue also for you!

@Rose_Languste As I’ve mentioned in your other post Why is TCS not on the Compatibility-List for the Opener!? - #3 by Rose_Languste

I’m sorry to inform you but as of 01.06.2022 upon a previous request by TCS TürControlSysteme AG
we have discontinued our official support for TCS intercoms for the Nuki Opener. Existing Nuki Opener setups can still be used.

Hi! Sorry, don’t read it yet! Should I disable the automatic firmware updates for the opener then!? Because I really don’t want to loose the opener functionalities!? Thanks!

Wow, that actually worked!!! I am so thankful for your reply! :slight_smile: The explanation also totally makes sense, even though I don’t understand why the bus would be occupied for the whole duration of that weird tone… “tütlütlüt” perfectly describes it by the way.

So I had to do a lot of guessing regarding the wiring of the ISW3030, but in the end it works.

It’s always a mess just blindly attempting things on a system you don’t even know the basics about. Watched lots of TCS Bus system videos last night. I also have the suspicion that my doorbell was not installed correctly, but who knows.

By the way is there a feature to simply open the door via the app? All I can do is set it to “Ring to open”.

Best regards from cologne!

Hi, no problem.

Although, we don’t plan to do any changes with regards to existing (TCS) configurations we have discontinued our official support for this brand. Firmware updates should therefore not break
existing TCS setups, but we are not actively verifying them anymore.

GREAT!!! Glad that I was able to help here! Have fun with it!
For your question, - yes you can open the door also simply over the app itself, just open the app and tab on the entry for the opener, then a popup at the bottom of the screen comes up, with a field what you can push for opening, - Also you can add Widgets to the Homescreen what shows buttons to push for the different functionalities like opening, - also on Smartwatch you can install nuki, and it shows then also buttons to control the opener or other nuki devices! Also it works with Google-Home, Alexa, Philips-Hue and ifttt, and others! - I have setup my system, that when I come home, the Geofence recognise that I am near and activates Ring-To-Open, then when I am ring the Downstairs door gets open and my locks are going automatically unlocked, so when I come out of the elevator upstairs, I just have to go in, - same as when I go away, the locks are locking automatically, - AND a few convenient things, like lights and tv are going on automatically when I come home, and are going automatically off when I’m leaving home, and a few other things! Also look and setup the Notifications-Settings, so for example you get automatically a notification when you coming near home, with a button to activate Ring-To-Open, that you just have to ring when you arrive, and other things! Let me know, if you need further help! Cheers!

P.s.: I think the tone is started over a digital-command, and so maybe the system waits for confirmation if the command is executed right, and the confirmation comes after the tone is fully played through without errors, and in this time a active connection is in place, where in this time the system cancels all other commands until this connection is ended, like it is when you and a neighbour push at the same time the opening button, then the first arriving command goes executed and the second goes cancelled, and it opens just one time and not two. On Installation, the Electrician told something like that, that the when the bus is occupied with any other operating, it cancel all other commands, until the momentane operation is finished, and the bus is closed in this time!

Ah I understand, thanks! Please let us know, if they will maybe removed fully sometime, that we what use the opener with TCS, can react and disable Firmware-updates for the opener, before the functionality goes missing, - but when I understand this right, this should not occur! Many thanks!