[Opener] 7630/x0 doesn‘t ring anymore

I installed my new Opener today with my Ritto 7630/x0.

Everything seems to have worked, opening the buzzer, opening automatically after ringing etc.

But after installing my Opener the bell did not ring anymore. After checking and double-checking all cables and connections I couldn’t find anything unusual and I couldn’t make it work.

What’s important to note is that the LED still blinks when somebody pushes the button, opening works etc. - it‘s just the bell that does not ring.

I ended up reversing the process and unfortunately it still doesn’t work. I assume that I‘ve broken some cable or something on the board when installing it.

So my question is more about a replacement unit than it is about the Opener. I hope to find some answers here, since the Ritto intercom is pretty widely used.

  • are there any things I can try to make it work again?
  • can i just buy a replacement or does it have to be replaced by a professional?
  • does the replacement have to be an exact match in terms of the model number? The 1763070 is available on amazon. Are they compatible?

Thanks a lot!

I can answer this myself:

Yes, I damaged the board, that was the reason the bell didn’t ring anymore. Yes, the 1763070 is compatible with the 7630/x0.

Thread can be archived.