Nuki Web - Bugs (deleting users)?


I’ve come across an issue with the Nuki Web (user management).
In short, I’m unable to delete a user under the main Nuki Web account.

Initially I had setup a user via Nuki Web (via email address and permissions to Main Door lock). This worked fine, but ended up deleting the user and permissions via the App under the Main Door lock. Again this was all fine.
However, I noticed that the Nuki Web was still showing the user even though the user was removed from the App.
I proceeded to delete the user and the associated permissions via Nuki Web - However it doesnt let you (i.e. Main Door - Error: Deleting authorization failed).

I have tried performing a full sync on the Main Door via the Nuki Web. However, the user is still there. When i tried deleting again its the same issue.
I’m now at a lost as to how one goes about cleaning up rogue users within Nuki Web?

This obviously appears to be a bug in the Nuki web application. Has anyone come across this or have an idea of how one goes about resolving this?


Anyone come across this and have any suggestions?
Spoke to Nuki support (online chat) today, but couldn’t help and now waiting for an internal team to response?

I managed to resolve my issue on the rouge user account. The only way i was able to remove the user via Nuki Web was to actually delete the device.