Nuki Smart Lock Pro 4th gen Notifications Nuki App Matter over Thread

I have changed from Nuki Smart Lock 3.0 Pro to a Smart Lock Pro 4th gen because of some Problems with the previous Generation and long exchange time of the old Smart Lock. Yesterday I connected my new Smart Lock to my Homey Pro Gateway via Matter over Thread. I can reach the Smart Lock with my Homey Pro and have two types of states. I know that with Matter 1.2 there will be a third state. I can also reach my Nuki with the Nuki Android App via Matter over Thread but I realized, that when the Smart Lock is connected this way, I do not get Notifications from Nuki App. When Smart Lock is connected via Wifi I get Messages about the state of the Smart Lock (Door was opened / closed / locked / unlocked /…) but I do not get this Notifications with the Matter over Thread connection. I can see that these states are logged in protocol but I do not get the Push Messages from Nuki App like it is when you use Wifi. Is this a normal behavior with Matter over Thread or is here an integration missing ? I use the latest Version of Nuki Android App and also the latest Stable Version of Nuki Smart Lock Firmware.

If your Thread router supports internet uplink the Smart Lock uses Thread for the connectivity to Nuki servers too. Notifications will not work if this uplink fails.

You can turn it off and revert back to WiFi by turning off “Remote Access” in the Matter settings and turning WiFi back on.

If you go in the Matter settings of the Smart Lock is “Remote Access” turned on and does it have a green check or a red cross infront of it?

The “Remote Access” in Matter Settings where turned on and had a green check. Yesterday evening Homey Pro lost his Wifi connection and it seems that the Thread Border Router crashed. Nuki Smart Lock switched automatically to Wifi but after Restart of Homey Pro and the Border Router was up again Nuki does not switch back to Matter over Thread. I had to restart Nuki by removing PowerPack and then Nuki established connection again by Matter over Thread. Is there annother method to switch between this two communication methods or would it be an idea to implement a restart button in Nuki settings to go back to Matter over Thread.

I think I have found an Issue. Today my Homey Pro had some Wifi Issues. So the Thread over Matter connection was still available but Homey Pro had no inernet access. Nuki seems to realize that there where no internet access and switch to Wifi. When internet access was back to Homey Pro, Nuki still used Wifi. I tried to activate “Remote Access” in Nuki App at Smart Home → Matter but Nuki did not switch completely to Thread over Matter and deactivate Wifi. The only way to solve this Problem was to remove PowerPack to restart Nuki. Then “Remote Access” was automatically activated.

The current mechanic (FW 4.2.x) is as following:
If Matter & WiFi are both enabled, the Smart Lock evaluates while it boots if it can connect via Thread. If the Thread connection is not available within 60s it uses WiFi.
Once every 24h it checks if Thread is now available and switches to Thread.
If it is on Thread and Thread becomes unavailable it does not automatically switch back to WiFi.

You can force to always connect via WiFi by turning off Remote Access via Thread.
You can force to always connect via Thread by turning off WiFi.
You can disable any attempts to connect to Nuki servers by turning off WiFi and Remote Access via Thread.

Ok, so I will Update to FW4.2.x Beta and try how it behaves in combination with Homey Pro. In the Moment I have installed FW 4.1.8 (Last stable Release).