Nuki opener + Ritto twinbus (4630 and 1723070)

HI guys,
can i get some help. I am having problems with the Nuki opener and my ritto intercom.
Nuki support is not really helpful. the person assigned to me replies after 2-3 days and then it just ignores every thing i wrote and just give me random answers.

I have a Nuki opener bought over Christmas and it does not work properly.
So I had a Ritto 4630/10 intercom. I went trough the setup process.
Here I had 2 problems:

  1. the opener did not detected when I was pushing the open button. it took 10-20 tries to register it.
  2. the opener could not open the door during the initial setup. it opened it once, and when ringing but the second time when it was doing it by himself, it did not work.

Contacted support, the lady said Ritto 4630 is not supported.
No problem.

I bought a ritto 1723070. installed it and it works. this one is supposed to be supported.

went again through the opener setup process. I had exactly the same problems. would not detect me pushing the open button and would not be able to open the door on himself.
at the last step i still said that he opened the door.
since then it works intermittently.
sometimes it opens the door just right for days, sometime (like today) it refuses to open the door. both from Ring to open and from the app.

i detailed this to customer support and the lady is still replying that 4630 is not supported.
so now i come here. anyone has any idea what I can do?
i am a bit annoyed as I like the system, but for me, it does not make sense if the opener does not work.
If i have to take the keys out to get into the building, i might as well keep them for 2 sets of stairs and open the front door.

Any advice what I could do?
Thank you.

Hi! Foto of wiring please!

can i describe it? otherwise I can put the photo tonight:
wire from b port of intercom goes to red and yellow wires from opener (via splitter).
orange and green from opener goes to port b of intercom.
black wire from opener goes next to wire in Port a.


here are the two photos.
today it happened again. ring to open failed (continuous mode), the log got full of notifications (debug mode is on) and buzzer didn’t buzz.
I could open it from the phone, but not from the front door button:(

really sad that I struggle to get support here.
for me I bought a paperweight from Nuki called Opener.
the connection is just unreliable. It works sometimes for months perfectly, while sometimes it does work randomly and then not at all :sob:
I had ok support, but the frist 10 messages when I reopen the ticket are completly ignoring my initial complain and running me through the script. I feel like the guy calling IT for a software problem and getting asked if I plugged the computer in.
now Ring is comming with an intercom which looks really appealing :frowning:

2 Likes

Hi, i have exactly the same problems. I will look for an other product.