Nuki opener cannot unlock unless responding - ISM 2404


I’m trying to install a Nuki Opener with a ISM 2404 NIDT, a very popular brand in UK’s former council-built houses.

The ISM 2404 seems to be built on the technical scheme of a Comelit 2404W, same ports, very similar board, as a matter of fact old ISM terminals had Comelit circuit boards inside.

It’s super hard to find ISM documentation online (since it’s not a consumer brand) I decided to wire the NUKI with the Comelit 2404W and it seems to work almost fine!

The ring is detected, the door can be unlocked. The only problem is that nothing works unless you receive a call first and, more problematically, unless you’d pick up the phone and answer.

When the ring signal is received, NUKI correctly tries to unlock the door, but nothing happens unless i pick up the phone, only then, the door unlocks.

As you can imagine, this defeats the purpose completely.

I tried to connect the blue button to various terminals, but without success, i tried with and without ring suppression, and equally no luck. I mean… The ring gets always recognized (i see it in the log files) nuki, always unlocks, but nothing happens.

Am I missing something? Is there something I can do to override the need to respond to open the door?

(Attached a picture of the terminal)

Thank you!

Hi There,
I don’t have the same terminal, but I also had issue with a responding configuration, I share with you the tricks I used.
I have a different model but it has a “call first” configuration.

The first thing to do when you set up it is to ensure you put a delay, for me 3 seconds between the call and the answer otherwise it doesn’t work at all.
It’s a bit tricky because the delay menu is only available when you have an opener already set up (chicken and egg…).
So you start the set up and follow it wherever you could and it basically won’t work. But then you can access the opener parameters and change the delay. Once it is done, restart the configuration again.

Second is to do the setup process in the “call first” mode meaning you have someone calling on your intercom during the first step of the setup which is not so easy. The rest of the configuration been as usual I would say.

The two tricks worked for me, hope it helps.
Best regards and good luck

1 Like

@tecsof Did you ever figure this out? I’m in an identical situation with the ISM 2404 NIDT in a UK ex-council flat, I’ve not yet bought a Nuki, but wanted to make sure it’s compatible before I went down the rabbit hole. Thanks!

Hi Chris, no luck unfortunately, I actually ended up messing the intercom which stopped working at some point.
I’ve returned nuki and gave up for now, if anyone finds a solution I’d be happy to try again.

1 Like

Thanks @tecsof

Yeh, I’ve basically done the same with our intercom. :grimacing:

So, I’ve played around with some of the solutions here and found a solution

‘Privacy mode on’ is the way to get the door to open with the Nuki app.

The downside is that there is no notification when the intercom is called and smart features like auto-unlock etc do not work.

I hope this somewhat helps somebody, hopefully, a software update in the future will help.