Nuki Opener and CODEfon MKT - Setup issues


I have the latest Nuki Opener firmware and the following intercom in my flat:

Wiring instructions:

This is the most common intercom in Hungary, unfortunately its not listed as a supported one in Nuki app, so I tried to install as a “Generic Bus” model as stated in the following guide:

As the instructions said I wanted to do the basic setup, but I had no success. Here is what I tried:

  1. Black cable --> BUS- and Red cable --> BUS+
  2. Black cable --> BUS- and Red cable --> BUS+ and Orange cable --> BUS+
  3. Black cable --> BUS+ and Red cable --> BUS-

The phone is inactive until someone rings to the flat at the main entrance. For this reason I cannot follow the instructions in the app to press the door opener, because nothing happens. I tried to ring the phone before the app ask to press the door opener. It sometimes worked, the app went to the next step, however the Nuki cannot open the door. Sometimes when the Nuki gave the opener signal, some weird noise came from the unit at the main entrance but nothing else happened. Also in this case, the phone stopped working, there were no audio signal, it seemed that Nuki took over the control totally.

Since its a digital system and it has only BUS- and BUS+ I dont know what else I can try? What instructions should I follow if I want to solder the Nuki to the opener button on the PCB?


Intercom website:

I have the same question.
@brnbs were you able to get it to work with your setup?

Are not intercoms what have to be activated (someone rings) for working, at all incompatible with the opener!? I think to remember, that I read that often, as I sorted out my issues with it.

@Rose_Languste what are you implying? Have you managed to retrofit Nuki Opener with CODEfon or a similar system?

Any help is appreciated.

No, I have a other system, but you wrote for your system, that the phone is inactive until someone rings, and that sounds strong you have a system what have to be activated on use, and for such systems the opener cannot work.

Did you figure out anything how to install it on Codefon system?

Nope. Haven’t tried it yet to be honest. Will post back after I give it a try.