Nuki lock and bridge is getting worse day after day

Sorry for the English

What the hell is going on with Nuki

My current setup is a
Nuki v2 connected to a first gen bridge (don’t know if there are any newer versions released?)
My phone is running android 9 on a one plus 7 pro latest App

The auto unlock experience is still not as it was on v1
I’ve send many complaints about how to set my own values but never got a reaction !

I know you are looking to make the app more friendlier but your doing the opposite

There was a beta version where we had the ability to set our own rssi value
this worked 9 out of 10 it was also very fast detecting my phone and opened the door immediately

Now it does work but only after waiting for 10 to 15+ seconds
App setting: slightly delayed

Don’t know when i’ve got my first battery warning but its been a while (mid 2018)
in the mean time i replaced the batteries several times
There are times i think they are nearly depleted and i am stuck with a closed door
but then a day later it opens like when installed with new batteries

Nuki Motor
Improved motor?? there are times i think its so fragile and it will break before it can even open our door

there is nothing wrong with manual locking or unlocking it is as smooth so it shouldn’t be a problem

Nuki v1 did it better if you ask me

Bridge API
At first it worked flawlessly but after reinstalling my bridge with the same smartlock
there are random HTTP 503 Unavailables
it barely works as intended so it completely unusable with home automation platforms

It does work when you unplug and quickly replug the bridge this will work for about ten seconds
once a request is made its again trowing you a HTTP 503 Unavailable again

Absolutely unacceptable at this price point

My overall conclusion is

a Smart home needs to be almost worry free but with the Nuki lock it isn’t
it unreliable, it contains many bugs, and also its advertised including zigbee???

You are releasing new products (wich is fine) but please fix your current products cos they are horrible now

If there was any alternative i would already abandoned Nuki

I have same issue since I upgraded my nuki second gen because HomeKit and Bluetooth 5.0 thing get a lot worse Auto Unlock 70% not working
Some times it take long time operation to open via HomeKit or nuki app
I felt I downgraded my lock I am going to reinstall my old nuki if this issue continue more

Dear @sand_Rr.

I can just add my two cents to the auto unlock feature.
Never had the v1 before so i cant compare it against it.

My Setup since ~3 months:
Nuki v2
Nuki Opener
Nuki Bridge
Oneplus 6T with newest OOS 9.0.16
Oneplus 5T with newest OOS v?

Issue with auto unlock:
I have really tried to stabilize auto unlock on my phones.
Tried different ranges (currently 200m), disabled all battery saving settings, tried various kernels…
The issue is that the geofence you define in the app will not be triggerd in time.
Sometimes (when i think about it) i take my phone out of my pocket before i reach the door and wakes it.
But also that does’nt help. The notification “you are near…” is comming to late (geofence triggers to late) So also auto unlock is not active when i am in front my door most of the time.

@NUKI: can you please fix this issue, because there are really many users with this issue when you check the forum here or amazon…
There is an app called Doorman which goes another approach as your app. Also the developer has posted here that he has contacted you regarding integrating a better soltuion in the main nuki app. He has’nt got an reply. Here is the thread: Auto unlock too late

Common, this would be a nice feature and you also advertise it, but sadly it does’nt work reliable.

Otherwise i cant complain about the functions, battery drain until now.

I want to add an idea for nuki.
Don’t get wrong and blame me, i am not android developer (c/c++ is where i am at home :slight_smile: and have just googled a little bit.

Here is my idea.

Define another geofence, say 1km around the home. If that triggers start an foreground service which requesting locations in an small intervall. Maybe this way the second smaller geofence (which activates auto unlock) gets triggered before the user reaches the door.
Here are some links i have collected:

Please Nuki look into it and improve this nice feature.


For all of you in need of a battery friendly, accurate and highly configurable fix, try the Doorman app (Android only)
It is free for the first 100 lock actions.
I haven’t tested with v2, so just let me know if it works.

The app was developed out of frustration. It doesn’t look very nice but works flawlessly every time as it uses a different approach to the challenge.
You might have difficulty with the setup. If you can’t get the API key right: create it in a web browser, copy it, email to your smartphone, copy/paste it into the nuki settings page of the app.
Instructions can be found through the help menu.
This is no money maker for me, just a solution to an annoying issue that should have been a fantastic product.
Help yourself and try it now.

Dear Kjeld.

I am appriciate that you solved the issue with an own app.
But i think it time for nuki to implemented working AU feature on android.

Does your app work with the opener? (phone has no BT connection when i am in front of the house door, it just has a connection over the bridge)


Doorman does not support Opener.


I deactivate the auto unlock and the beta door position to try to have a normal experience.
Right now I have some problems with the auto lock.
Sometimes, the door did not lock at all (I change the time limit and it works again until it stop working and I have to rechange the time limit).

Let´s hope they solve current features before exploring new areas.


I know your app is working flawless. The point is, if you pay this much you shouldn’t need another app to open the door.

Nuki keeps releasing new products but instead of creating new products they need to fix their old ones

This auto unlocking feature is almost shitty for a year now (sometimes it works)

The bridge is also worthless as it is trowing HTTP 503 Unavailable again errors

It worked but why the hell did it stopped working

It would be fantastic if the original app does what it should do. However, it doesn’t.

I solved my 503 and 423 errors by placing the bridge closer to the lock, and further away from electrical interference (the fuse box).