Nuki Bridge often returns 503 - not working correct


I have the Nuki Lock and the Bridge since more than 1 year and I am meanwhile really frustrated!
I integrated the Bridge into my smarthome and query every view seconds the state with the /list API call. The most time I get an Error message from Nuki Bridge 503
I thought that this is a bug and will be solved soon per firmware update but its sill not ok!
The distance between Nuki Lock and Nuki Bridge is around 1.5m
I have also the Problem that somethimes if I submit an open request to the bridge 5 Minutes later the Nuki bridge open.
I dont know why!
Can you help?

Usually a 503 error means that your integration is throwing to many requests at the bridge API, because the bridge can handle only one connection/request at a time:

Furthermore the bridge does not cache or retry requests. So if something is executed with 5 minutes delay, it must have been coming from your integration with a 5 minutes delay. You can use the /log command of the bridge API to debug such cases.


I checked the traffic with wireshark and found the overlapping requests!
Why is there a limit of 1 request at the same time?
Maybe it can be improved for requests to the Bridge only!
So if a reqeust eg /list is called that this can be done more then 1 instances at the same time.
The other problem with the 5 min later was an indirect problem caused by 503 in smarthome system.
Now it is solved.

The hardware can not handle more than one concurrent request.